Forum

VVVV.Audio Discussion

As the audio pack is just a preview release, feedback is very important. May it be from a general ease of use perspective or different fields of its application.

@Sune already started and opened a bunch of issues on github. Since not so much people browse github regularly, i wanted to bring the dicussion to the forums.

Some issues rise more general questions: Audio node confusion

  • Should the category be named VAudio (or any other better name you come up with) to distinguish the nodes from the other audio nodes which are already there?

Or: SystemFolder (File) should have a reference to the VST folder

  • How should the file references to vst plugins be managed? should there be a vst folder in every project to load the plugins from, or should there be a global reference to a vst folder on your machine?

Others point to limitations of value exchange between the vvvv thread and the audio thread: MultiSine keeps playing it is when saving

So, if something like that comes to mind now or in future, just post it here.

Would it be possible to get Adjust System Time on Filestream (Audio) so it can be used with Sync (Network FileStream)?

the concept of time is very vvvv-style pull based.
the FileStream has no knowledge of time. the downstream node requests a number of samples and the filestream advances for that amount of samples. so it would need a node below the filestream which pulls more or less samples for each buffer and drop samples or add samples to adjust the speed.
have a look at the Resampler node in the AudioFilePlayback.v4p example. this node is doing exactly that. but it uses very high quality filters to eliminate artefacts, and they introduce delay. for small speed changes a much simpler method without delay can be used…
but now that i think of it, the FileStream could do that itself and a speed pin could be added… if you adjust the speed pin, the FileStream node does something like that on its own. will try that…

and if anybody is interesed, the pull based time idea gives the flexibility to build branches in the audio graph which run in different sample rates. but that in conjunction with multiple downstream nodes connected to one output pin introduces a tricky problem for which i wrote a thread in the KVR forums. but over christmas they locked the forums for an upgrade and there is no progression on the topic:
http://www.kvraudio.com/forum/viewtopic.php?t=399897

some users have reported, that the audio operators (+, -, *) are not working.

one user even complained that the new WaveForm node is not loaded…

as this all works on my machine, it would be great if some of you could test them with the new V3 build.

thanks!

think i found it, the plugininterface has changed. there are now 2 versions, one is for the current beta31.2 and the other for all newer vvvv versions. hope that fixes the troubles. please confirm.

trying to use the fft(vaudio sink) node

  • audioin node was red
  • used audioengine node to select the desired soundcard
  • audioin node no longer red
  • fft(vaudio) sending nill as output
    am i missing some nodes ?

audioin test.v4p (5.5 kB)

you don’t need the AudioOut, this might generate a feedback. but you have to enable the audio processing by setting Play of the AudioEngine to true.

The FFT size depends on the ASIO buffer size, a buffer size of 512 is a good trade off. a buffer size of 256 gives less delay but lower resolution…

i see; now the audio is working
could you please explain/demonstrate the use of Abs with the fft output? not sure what is what with complex numbers :thanks:

audioin test1.v4p (12.0 kB)

just connect x to real and y to imaginary of the Abs node:

audioin test1_0.v4p (12.2 kB)

mmm,
i think i have a problem with fft.
I remember it worked, so don’t know if it’s comething related to asio4all instead.

Basically, i can hear the microphone from audio out, but if i attach an fft it outputs nil, and sometimes 0, instead.
but no fft reading anymore.
This is happening also with a fresh new patch, where i put the engine and the audioin.
the fft is set to 0, and when i attach audioin to it, it becomes nil.
mmm…

if you open the ASIO4ALL control panel it tells you whether it was able to open the sound card input/output or not. so check if another software is using the sound card and what the AudioEngine node tells you about the available channels.

Yes, i know but it’s not a problem about asio4all, because i can see all is working, and i can also hear that input, so it is working. simply the fft refuses to see it (i mean that if i atatch it to audioout i can heat it correctly).

But now i have another, bigger, problem.
I’m porting all the patch i’ve done on its final destination (an all in one computer from msi, very poor hardware).
All seems to work quite well, except for the vst loader.
What i mean is that it is not working at all. I can try with every vst (also the girlpower example) but the vst node dosen’t do nothing. And all the output pins are NIL.
No way to openup the interface, or to pass values and hear something. simply, it dosen’t work.
I’ve tried all, also downloading the vst.net 1.1, but nothing worked.
the pc has an integrated realtekHD, and it’s on windows 7.
what could it be? and what should i try to resolve it?

in the meantime, i’ll try to connect an external audiocard, just to see if it’s a problem related to the audiocard, but i don’t think so, because all the other features is working fine, so seems more something specific of the vst management.

let me know if you think there’s something else that i could try…

thanks

strange thing, also the “bass” vst loader dosen’t work (same behaviour).
So i’m starting to think that is something more global, related to this configuration.

But, i’ve tried to download this vst host software (http://www.hermannseib.com/english/vsthost.htm) and it works pretty well in loading the vst, so it’s not something global on my computer, but related to the vvvv enviroment.

every help or hint is really appreciated

last observation: if i put a render tty to see what’s happen, i can see that the point is that the system cannot run Jacobi.interop…

here is the render tty transcription:

****************************************************__
00:00:59 ERR : Exception occurred during creation of plugin: The composition produced a single composition error. The root cause is provided below. Review the CompositionException.Errors property for more detailed information.

  1. Impossibile caricare il file o l’assembly ‘Jacobi.Vst.Interop.dll’ o una delle relative dipendenze. Impossibile trovare il modulo specificato.

Resulting in: An exception occurred while trying to create an instance of type ‘VVVV.Nodes.VSTHostNode’.

Resulting in: Cannot activate part ‘VVVV.Nodes.VSTHostNode’.
Element: VVVV.Nodes.VSTHostNode --> VVVV.Nodes.VSTHostNode --> TypeCatalog (Types=‘VVVV.Nodes.VSTHostNode’).

Resulting in: Cannot get export ‘VVVV.Nodes.VSTHostNode (ContractName=“VVVV.PluginInterfaces.V1.IPluginBase”)’ from part ‘VVVV.Nodes.VSTHostNode’.
Element: VVVV.Nodes.VSTHostNode (ContractName=“VVVV.PluginInterfaces.V1.IPluginBase”) --> VVVV.Nodes.VSTHostNode --> TypeCatalog (Types=‘VVVV.Nodes.VSTHostNode’).

Resulting in: Cannot set import ‘VVVV.Hosting.IO.PluginContainer.PluginBase (ContractName=“VVVV.PluginInterfaces.V1.IPluginBase”)’ on part ‘VVVV.Hosting.IO.PluginContainer’.
Element: VVVV.Hosting.IO.PluginContainer.PluginBase (ContractName=“VVVV.PluginInterfaces.V1.IPluginBase”) --> VVVV.Hosting.IO.PluginContainer

00:00:59 - : To help us track this error down, enable the ExceptionDialog via the menu or starting vvvv with /showexceptions.

****************************************************__

also, the same happens on both x86 and x64 fresh installs of vvvv

make sure you use 32bit plugins only in the 32bit vvvv version and vice versa.

also check all the file access rights… maybe something is messed up there. maybe start vvvv as admin to check whether that changes anything…

tried all that already.
About the plugins, i have the problem also before loading a plugin, because it refuses to find the jacobi.vst.interop immediately, when i call the vsthost node.
And i’ve already tried both versions, and with and without admin rights. what i did’nt done is changing the access rights, and now i’ll try it immediately.

Also started to run all as admin, from the setup of vvvv, to vvvv itself, but no luck.
i’ll let you know in a moment if could be something related to the files access rights, but after running as admin, i’m not sure that can be the problem

nope, no luck.
I’ve set all the fill access rights to “complete” for all the users, but nothing to do.
It dosen’t seems to find (or load) that file.
i’m out of ideas :(

just for information, this is an amd processor, with integrated amd radeon.
for what that matter, this is the first time from a long time i’m using an amd configuration, so don’t know how can this be relevant…

is it the original VVVV.Audio download? you said earlier that you downloaded VST.NET 1.1… you should use the dlls in the VAudio download because the pack is compiled against them.

i have no idea how amd could interfere with that. only idea i have is that the Interop dll does the conversation between native code and .NET so it might be possible that it was compiled with optimized intel instructions which the amd processor does not have. but this is very unlikely… you could try this out by replacing the x64/x86 interop dlls in the pack with the /Debug versions of the official VST.NET download, they should be compiled without optimization…

otherwise i have really no idea what else could cause this trouble…