Forum

VL.Devices.Nuitrack

Probably too late for this request but the time to add Nuitrack support to VL has come!

We are opening the discussion to anyone interested to share their use cases, needs, ideas and experiences with this tracking API in order to make the most of the upcoming nodeset.

Even though we are still pretty much on the research stage, the main intention is to make the nodeset as similar as possible to VL.Devices.Kinect2 which is still WIP but has already laid the groundwork for Skeleton tracking.

We see there’s already been an attempt here, hope to get some input on experience by @neuston.

Please do join the discussion and bring any thoughts you have on the subject to the table.

To test the current progress just download and install the nuget package as explained here.

The command should be:

nuget install VL.Devices.Nuitrack -prerelease

Also for the brave hearted, we have a github repo at https://github.com/vvvv/VL.Devices.NuiTrack.

Cheers and happy patching!

2 Likes

Hey @ravazquez,

Stoked to hear you’re on it!
Still quite surprised it’s not appealing to more people out here.
We’ll be happy to beta test, we have a bunch of Intel / Orbbec / Kinects here to check out performance across hardware.

Probably too late indeed for our upcoming project but we’ll be looking forward to try this out!
(if dev is coming out pretty easy/fast, do hit me up though!!)

One first suggestion: I have been looking into the OFx.nuitrack addon’s .h real quick, and I think the face tracking has not been wrapped (should be easy to add, but still a bummer it’s not included in the contribution by default imho).
The feature is turned off by default in nuitrack’s config file, and it has to be polled separately and returns a JSON string. Face info is hidden under “User Instances” in the API docs, a bit hard to find at first, here is the link.
And here a blog post they made on the subject.
I think it would be great to have this supported to not look back to Kinects and Kinect nodes just for face tracking needs ;)
What do you think?

Best
T

1 Like

Never had a chance to use Nuitrack, but we also have a bunch of Kinects and RealSense here, would be happy to help with some testing :)

1 Like

It is such a great news! But I have stopped trying Nuitrack+VL since my last post. Thus, I cannot input more. Instead, I integrate Nuitrack in vvvv by traditional c# plugin. Normally, it works (but its license checking process will block the opening of new patch windows )

1 Like

First draft nuget with RGB and Depth Reactive nodes + simple Overview help patch now available! Check first post or github page for more instructions but in summary:

nuget install VL.Devices.Nuitrack -prerelease

Hi ravaquez

tried it with:
Orbbec Astra Model:Astra
Microsoft Kinect v2
vvvv gamma 2019.1 preview 411

Overview.vl is loading and I see VL.renderwindows and VL.nodes appearing - then sudden death with Orbbec Astra, with Kinect I even see something in the renderwindows but frozen and then also sudden death - no error message appears

how can I have a look at a kind of a logFile so I can maybe tell more

Greetings
Daniel

Hi @CeeYaa, I updated the installation instructions yesterday, please make sure you follow all the steps here: https://github.com/vvvv/VL.Devices.NuiTrack/blob/master/README.md

Basically your Nuitrack SDK install should be working before you attempt to use the VL nuget.

If you can see data coming in from the steps in section “Activate Nuitrack” then VL should also work.

Please report back with your findings.

Cheers.

Hi @ravazquez

Stupid me - NuitrackSDK not activated - NuiTrackTrial license is linked to one PC, after I got a new key - NuitrackSDK works and also you VLpatche Out Of the Box - as usual, looks good - after 3minutes quit but this is the TRIAL - now I have some testtime, if I should go for a PRO

THX again ravazquez
Great contribution

1 Like

Glad to hear you got it working, and remember it is still very much WIP.

As of version 0.1.6-alpha Skeleton tracking nodes have been added.

Please test and report.

1 Like

Hi @ravazquez

Thanks for the Nuitrack lib,
I tried to run your help patches in beta 39, older rc version(38.2-4278) latest Gamma and the latest alpha as well, but somehow always failed and vvvv just chrashed.
My nuitrack is an activated pro licence and the nuitrack_sample.exe and the VL.Devices.RealSense are working fine with my Realsense D435.
Can you help me how can I fix it (tty render didn’t showed anything)?

Thanks
Zsolt

Hi @KX, did you follow the steps detailed here: https://github.com/vvvv/VL.Devices.NuiTrack/blob/master/README.md?

Specifically:

  • Setting environment variables
  • Activate Nuitrack
  • Getting an activation key

You should not need to build the C# project.

Hi @ravazquez,

Thanks for your answer, I did, I uninstalled than reinstalled the latest nuitrack version, than I generate lic. key on dashboard and activated with Nuitrack activation tool… (one year windows licence

), plus I checked the environment variables and it was correct.

Maybe some version difference between vl and nuitrack.net, they made the Git version at 6th of november.
net

many thanks
Zsolt

Hello again @KX, I will need to have a look at it then but am afraid I will need some time since my schedule is a bit tight these days and I have not really touched Nuitrack in a bit.

How much of a hurry are you in?

Hi @ravazquez,
Sorry to not reply, it would be nice to try out in the next few weeks how is it working, because we need to decide which tracking we gonna use.

Many thanks,
Zsolt

Hi @KX, there seem to be some backend issues with this lib.

@azeno is already aware of them and will have a look when he has some time.

We will update this thread when we know more about what is causing all this.

Thanks for reporting.

1 Like