SceneWindow bug


i just installed vvvv gamma 2021.3.1 on seven computers (bootcamp, windows 10). On two of the computers the stride helppatch “Scene Graph basics” works fine, on 5 of them i get a pink error on the SceneWindow Node: Object reference not set to an instance of an objetct. (= no window is created).

Please help me with this.

Thank you, Kathl.

DIfficult one to help you with. Can you see any significant differences between the machines, in particular the GPUs they run? I run Bootcamp without any problems, but with an old Nvidia Card. AMDs have had issues with Stride. Also, Mac laptops may be using the integrated (intel) GPU instead of the discreet one. Some one here may be able to give you a pointer about how to figure out which is running

I just checked the settings of the graphics card - they are the same on all of the computers. Radeon Pro 555K - same driver.

I also tried to deinstall and install the new version. But I always have the same problem. (Here you can see the description of the error.) - I just opend a basic-help-patch from stride.

Do you have any ideas, what I could try?

do they have a different monitor setup? in your screenshot we can’t read the full message… but it seems to indicate that the display settings could not be read.

Wow. Thank you! Now they have the same setting - important change: 100% scaling.
Now it works. It needed a restart.

Thanks again!

can you say which driver exactly? if this is not the newest one available it would be interesting to hear if the problem still persists with their newest driver. because obviously setting scaling 100% is not a solution and we’d like to get to the bottom of this.

This might be related?:

And I also wonder if this maybe has to do with the GetBoundsRight (Internal) operation of RenderWindow which uses VL.Core.UI.DIPHelpers. I checked them out briefly when looking into this. And from what I can tell they seem not to take into account different scaling settings on multiple monitors.


It also happened to me on my laptop with the stable version(2021.3.3). However, when I installed the 2021.4.0-0125, somehow it works. Just for your reference.

thanks for the report, we recently fixed a bug regarding this. let us know if it happens again…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.