Forum

Problem with mouse tracking in a renderer

@microdee: hi ! did you have some time to find where is the problem with vpn package ? i m completely stuck about mouse tracking problems, and using you package seems the only way to solve this . the zip non vpn version is not neither ok
Thank you :)

yes, as I said, extract vpm itself with 7zip, not the File Explorer unzipper

sorry @microdee but that s not that simple (helas)

  • done unzip of vpm with 7-zip.

  • clicked the link for mp essentials, encountering connexions to the contents (message, mdcore, mdessentials ) not stable: sometimes thruth the vpn app ( agree / next not doing ther job).

  • finally accessed to all 5 packs

  • Installed in my dropbox the packs folder, copied it to my vvvv inside my dropbox.

  • Red nodes on Handlefromcursor and windowpos

  • Tried to install it directly in VVVV folder in my dropbox

here is what i have:

Question is the installation with links somewhere or does it provide it to be put with CTRL C directly inside the pack folder ? Thank you for your answer

@karistouf: Try another folder that is not in your Dropbox.

thank you bjoern, pffff i finally success in vpm using:

  • needed to restart windows ( an exception remaining in system memory while vvvv closed)
  • installing on desktop then copying to my vvvv folder in drop box

it works !

@seltzdesign, thank you, with your solution it saves my day, it was quite painfull.

@joreg: still not understanding WHY a simple tracking cant no more be done in VVVV beta as its a basic common feature, and needs complex solutions

@microdee thank you for your help. rahhhhh finally it works. the VPN has finally only downloaded md essentials. dont know why from the same link i have (or not) all the packages in installation, nevermind. its great to have created this tool.

@karistouf aahh maan in vpm you have to select the folder which contains the vvvv.exe, or vpm already finds the vvvv which has the file association. the error message also tells you this ("… install vvvv first"). my packs won’t work if they are not in the packs folder of vvvv.

it shouldn’t care about dropbox but I’m pretty sure you don’t have a vvvv installation directly in your root dropbox folder.

thank you microdee, but its surely mainly a problem with dropbox (either its non active or set to closed state) and vpm.
anyway your great stuff is working now, BUT im still in trouble with this f****g tracking mouse.

if i connect the output of the left mouse to do a simple s+h i have back all disfunctionnement of the tracking renderer, getting a bouncing coordonnate.
The patch is working stand alone ok, but in the environnement with all graphical stuff, i m coming back to those ****** behaviour.
the tracking is done with a stylet, so i need this left click working correctly…

where should i look for ? this is really a nightmare…

get_absolute_renderer_coords.v4p (18.2 KB)

Ok, i have founded where is my problem, it is related to Point Editor.
Neither if i disable mouse reading and point editor VL its presence is just making the bouncing effect…

Here is a simple Main showing this painfull trouble

debug.zip (7.8 KB)

Hi @karistouf,

we’ve tried to understand what is happening in your scenario.
As you’ve seen, the PointEditor (see its helppatch) is working properly on its own (both DX11, DX9) versions, without any jumps of the mouse. So there is something else in your bigger system.

As a quick solution for you to try now:

  1. on all Mouse (Devices Window) nodes disable the ‘Cycle on Mouse Down’ config pin in the Inspektor. (to find all instances of the Mouse node, open the finder (Ctrl+F) and type there ‘< mouse’).
  2. don’t use any Legacy Mouse nodes

Your ‘debug.zip’ will work if you open the subpatch which contains the PointEditor, open the PointEditor, find there the Mouse node and disable ‘Cycle on Mouse Down’ config pin.

Of course it’s not the final solution, we will investigate further.
Is it possible that you share the patch which we see in the vimeo video?

Hope this helps a bit.

Best,
Anton

thank you robotanton

outside the structure the trick is working, but not inside the structure
mouse node called only in tracking node

i have sended a link to the folder in my dropbox to joreg (moderator or yourself are not message-sendable from https://discourse.vvvv.org/groups/moderators)

thanks for your help !

I think what karistouf means is that the defualt behavior of Mouse (Window) is kinda meh. The Cycle Cursor On Mouse Click option is hidden and on by default. It jumps back to its original position once it would go over the edge of the window. I understand the intention and it’s a weird way to solve anything but what’s truly annoying with it that once the mouse button is released, the cursor jumps to the position where it would have been without cycling it. Or in intuitive phrasing the cursor jumps to a seemingly totally random position on the screen(s) once finished dragging. It kinda eliminates the purpose of keeping the cursor over the window while dragging and introduces all sorts of other weird behaviors on other mouse related thing not expecting this.
What’s the exact reason behind this? Can we have it off by default? The default camera modules have all Mouse (Window) in them with this setting being true.
I’m doing an alternative approach for camera movement for years, use the RawInput to get the mouse delta and then reset the cursor to it’s original place before dragging, every frame until dragging. So the cursor stays at the same place while dragging. I use this for dragging values on ReoGrid too, except not with RawInput of course but the behavior is the same.

thank you microdee, i will try to be more clear:

the patch alone with the cycling thing off is ok.

But on my (workinprogress) actual project, the behaviour is still present.

I have no other mouse node than the tracking one.

It means i inherit somehwere from other DX11 renderers in the chain ( texture work for example) of mouse default setting cycling thing.

@robotanton AND @joreg any news with the trouble of the mouse ?
sincerely yours

I can confirm that I am seeing the same behaviour. I have just one Mouse (Devices Window) node in our huge patch and turning on or off the “cycle on Mouse Down” does not change the behaviour at all.

I still get the cursor jumping back while click-dragging. It becomes super annoying when you have a UI and you have some sliders close the the edge. You click-drag the slider, but if you overshoot and hit the right edge the cursor jumps back and the slider is back at 0.

So yeah, either the setting in the Mouse node doesn’t work or there is some other factor impacting the behaviour.

Mouse Events also come out of the DX11 renderer, but it doesn’t have the option to turn on or off the behaviour so I suspect that its that. Is it possible that is an answer @vux?

I can also confirm that in a new patch if you just place a renderer (EX9) and a mouse (devices window) node you can get the behaviour to change with the cycle flag. If I have that same patch open while our big patch is open, the flag doesn’t do anything.

But what I don’t understand is why the flag is on the Mouse node in the first place. Shouldn’t it be a flag on a renderer, so that regardless of what mouse nodes I have I can enable or disable the behaviour per renderer. How was that ever supposed to work for larger patches with more than 1 renderer, where you might want different behaviour in each?

thank you seltzdesign, feeling less alone :)
hope this will be solved…

@karistouf yeah, I think this needs to be solved. Interestingly, the Mouse (Devices Desktop) also has the cycle behaviour (off by default though) and can do that cycle behaviour even when vvvv is in the background, which is kind of interesting. It suggests that the mouse is actually being manipulated at a very basic level.

So yeah, I’d say don’t let the Mouse node decide what to do inside a renderer, but let the renderer decide. If you have a renderer you don’t need the mouse node anyways, since the renderer has a mouse output anyways.

the behaviour inherit from other process … i m completely with you using only mouse from renderer…

@karistouf and @seltzdesign, it seems quite odd that it works in a small patch but not when other nodes are involved. so can you do a global search with finder (CTRL+F) including modules like this:
< mouse
with the checkbox for search modules enabled?

there has to be some node that sets the cyclic pin. if there is one, try to switch it back and forth this might reset it.

as i said previously, the mouse node is used only the tracking example.

there is someone else interfering with it