Problem connecting Alembic with Stride

Hi there,
I was trying to use the meshsplit from stride to get the positions of the vertices of the mesh. Is there a way I can work out this problem?

Kind regards,

hey yungbroco, the answer is in the screenshot you sent, if you reed the help text in the tooltip. note that there are different MeshSplit nodes and you have to use the correct one for the mesh at hand, ie in your case the one with version Pos3Norm3Tex2, matching the declaration of your mesh as we can see in the IOBox.

I also saw that and tried adjusting it to MeshSplit(Pos3Norm3Tex2) but the error message only changed to “Object reference not set to an instance of an object”. The above screenshot is therefore misleading.

in this case, can you share the patch and model so we can have a look?

I used the same model of the alembic scene of torinos in his helppatch and then just added the meshsplit! If you still want my patch let me know but I feel like it is quicker just to open his helppatch and add the node “meshsplit(Pos3Norm3Tex2)”. :)

Hi yungbroco, the problem is that MeshSplit is trying to get an IndexBuffer that does not exist. VL.Alembic does not create IndexBuffers to work efficiently when parsing geometry. You need to create your own without GetIndices inside. See help in MeshSplit.


Indeed. latest previews now have this fixed.

Thank you, that worked! Somehow the Getindices in the if statement caused the issue. When removing it, it worked again!

please clarify: are you saying the latest preview doesn’t work out of the box?

If you mean with out of the box that you can connect the MeshSplit Pos3Norm3Tex2 (Stride) to the GetMesh(Alembic) Node, no that doesn’t directly work. As Torinos explained, the Alembic Mesh does not have an IndexBuffer, therefore you have to remove it in order to make it work. Hope this clarifies it!

Maybe for people who haven’t worked with alembic but only with stride, it would be handy to have as a default an additional meshsplit node in VL.Alembic or VL.Stride without the IndexBuffer inside, as an idea;)

ok, so please note that when you go to downloads, we have stable and preview versions. what i meant is that in latest preview versions, this issue has meanwhile been fixed.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.