Forum

Error exporting Project

Hello,
I am trying to export my project but there seems to be a problem with the AssetCompiler.
Does anybody know a solutution for this?

That’s the Logfile:
error.log (97.8 KB)

I had similar errors, they might be fixed in previews, but I had to put all my .vl files into one main one (not nuget libraries) There was an error in the last preview that tried to replicate shaders for some reason. So try that, if the latest previews dont work

yes, this should be fixed in the latest previews. there should be no special document structure needed for this to work.

see also:

1 Like

Ok thanks i’ll try that

I’ve tried exporting it with the newest preview version but i still get an error.

preview.log (3.1 KB)

You’re also running into the TLS 1.2 not enabled issue. Please have a look at my post here.

ok thanks that seems to fix it but now i get this error:
preview2.log (97.8 KB)

Aha, interesting. Just pushed a new version of VL.Video.MediaFoundation - does it help if you upgrade to that one?

Cool thanks. I am not even using the MediaFundation Nuget anymore. After deactivating it it worked. Buuut now if i try to start the application i get this error:
exception.log (37.5 KB)

Hm ok, well that sounds like a file can’t be found in the output directory, have a look at https://thegraybook.vvvv.org/reference/hde/exporting.html#assets

For most of my assets i am doing it that way but i will also save pngs to a path which is not in the application folder and then i want to load them again from this path. Is there a way to use absolute paths?

not exactly sure how you see problems with absolut paths. of course you can always use relative or absolute paths. maybe elaborate your usecase a bit so we can understand your problem.

in the end it was a problem with my folder structure and one bang at the wrong time.