Forum

Export Problem: Gamma 3.2 and anything Skia

btw
@Elias when I try to export with Gamma2021.3.3.0123 I forgot to mention that I get the warning:

[Warning] Unable to load the service index for source https://api.nuget.org/v3/index.json. 

and a lot of these Errors but all Stride Related here

[Verbose] Resolving conflicts for .NETFramework,Version=v4.7.2...
[Error] Unable to find package Stride.Core.Assets.CompilerApp with version (>= 4.0.1.1400)

As you can see from detailed log of the preview build I posted above the restore uses %AppData%\NuGet\NuGet.config and the one in the generated src folder (src\NuGet.config).

In both your cases it fails to read from nuget.org - therefor you get all sorts of errors, like that it can’t find Stride, Skia etc.

Did you check those registry keys from the Microsoft article I linked to above?

sry, I was too lazy
@Elias - I went trough the Microsoft article


and run all commands - so I don’t know which one was the correct one but now it exports

and \AppData\Roaming\NuGet\NuGet.Config has the line:

<add key="nuget.org" value="https://api.nuget.org/v3/index.json" protocolVersion="3" />

and Documents\vvvv\gamma-preview\Exports\src\NuGet.config has the line

 <add key="vvvv-public-feed" value="http://teamcity.vvvv.org/guestAuth/app/nuget/v1/FeedService.svc/" />

strange was - first export with Gamma2021.3.3.0123 took 12minutes

I could export “sprayexample” with Gamma2021.3.3.0123
I could export “sprayexample” with Gamma2021.4.0.0073

thank you for help elias - now I know

@CeeYaa Glad to hear it finally works for you!

@Hadasi If it still doesn’t work for you, here’s another build you can try - it explicitly enables TLS 1.2 on our side, so we can be sure that isn’t the culprit anymore. I came across this myself while investigating something completely different.

error.log (3.4 KB)

I’ve just tried updating a project to the latest preview, I’m not using much in the project,Kinect2, net MQ, elementa, stride and media foundation. Export fails.

From the logs you’re also affected by that TLS 1.2 security stuff. No idea why this now pops up all over the place. The fix I mentioned above wasn’t yet merged in the preview you were using. Just pushed a new version (0083) which explicitly enables TLS 1.2 on our side before doing the nuget restore - can you try with that version please?

error.log (97.8 KB)

Still unhappy :(

This is a different error though. Can’t find Microsoft.Kinect.Face - anyway we can reproduce this on our end? Maybe you describe what packages you’re using?

errror.zip (19.9 KB) (patch)
Here is yet another different error, with a patch with just kinect and stride in. Doesn’t like kinect for some reason

and log
Another Error.log (97.8 KB)

Jesus, seems you stumbled upon something very special here :/

Root cause is that the Stride asset compiler can’t load the Microsoft.Kinect.Face.dll because of this - and the very bad news is that there’s no immediate fix. Only workaround I can think of is to remove the entire Face reference and all nodes with it - which is obviously only an option if you don’t make use of it.

Otherwise you’re out of luck as long as we don’t have a fix in Stride. Will open an issue there.

1 Like

Ah, ok, I’m just using what is in that patch, skeleton and depth, how do I remove the face reference, do I have to remove it from the nuget? (I’ve always been good at finding the weirdest errors, its like a superpower!)

1 Like

Any clues as to how to remove kinect face, I’d like to export to an app to see if that gains me any performance, I presume so, as there is no gui, my patch is almost running perfectly on a latte panda with an atom Z8350, it would be great to get it fully working on it.

Removing the face dll from the nuget gives me an error still

error.log (97.8 KB)

@catweasel. Attach your patch maybe?

https://discourse.vvvv.org/uploads/short-url/d16rehhKiOx4jeYpaLlu95AHRN1.zip its in a post above. I have also removed all references to face in the VL nuget patches as well as the face dll

Oops, missed that.

@cat Tried (with 2021.4.0-0083) and it worked. Maybe you missed something while defacing :) the Nuget?

Here is a version of the package with my changes:

My superpower again, even with your version I still have the same issue, same build of gamma, downloaded the patch from here again, even deleted the dll which you hadn’t, and unhappy exporter!
Thanks for testing though!

Have you tried without deleting the DLL?

@catweasel try deleting the export/src folder and exporting again.

Wrong nuget folder! (who knew there were so many, probably everyone, but me!)
Successful export, thanks!

2 Likes