Forum

Beta27 bugs

Hello.

After installing addonpack to the beta27 folder i can’t see any shader or camera node in my nodelist. When i opening old patch, that contains shader or camera node, that nodes appears red. I tested without addonpack installed - all is ok.

Also, looks like in some conditions after running crack exe i can’t see any VVVV window, except renders. Pressing ALT+TAB causing VVVV to crash. Pressing “unregister all” in crack window and checking all check-boxes again solved this problem.

UPD:
Solved addonpack problem, looks like i was a little bit confused by new directory structure and automatically unpacked all folders from addonpack folder to the VVVV root. But i found new bug - looks like we don’t have Box2dNodes.dll inside addonpack\lib\nodes\plugins folder, only help patches.

ups, thats right… they are supposed to be in the .zip but somehow our build server decided not to copy them… shame on him. lets see what we can do about that after dinner…

autch, my bad, here is a new pack with vuxens stuff inside:
addons_45beta27_02

sounds like Addflow not being registered, ie. the Addflow light should be red instead of green in such a situation. if can can reproduce a situation where Addflow shines green but still you don’t see patch-windows please let us know how you arrived there.

beta27 + addon27_02, crack is full green
but vvvv can’t load (keeps freezing on start up)
without addon - the same
b23, b25.1, b26 are working as expected

Just a little one

According to the new structure, all assets should go in the \lib\assets\ folder, but the map in ( vvvv user map ) is still in the girlpower folder.

Sune

and another tiny one, the headline of Polyline (SVG) is Polygon.

Edit - headline of the help patch

@dimix: interesting. can you /logstartup this and upload the log here?
@sunep: thanks for the polyline. the \assets holds rather commonly reuseable stuff, individual demopatches keep their special stuff.

@joreg: sure, but how to get log file?

see: commandline parameters#logstartup

  • 15:35:21.581 everything you know is wrong
  • 15:35:21.591 creating SplashScreen
  • 15:35:21.604 Adding lib\thirdparty to PATH.
  • 15:35:21.605 creating GClock
  • 15:35:21.625 creating GMainloop
  • 15:35:21.625 creating GLog
  • 15:35:21.625 creating GApplication
  • 15:35:21.626 creating GGlobals
  • 15:35:21.689 creating GNodeFactory
  • 15:35:21.707 creating Gex9Base
  • 15:35:21.716 Direct3D initialized.
  • 15:35:21.773 ExceptionDialog is disabled. Start vvvv with /showexceptions to enable it.
  • 15:35:21.805 enumeratig Game Devices…
  • 15:35:21.884 found Game Devices:
  • 15:35:21.885 enumerating Midi Input Ports…
  • 15:35:21.885 found Midi Input Ports:
  • 15:35:21.885 enumerating Midi Output Ports…
  • 15:35:21.885 found Midi Output Ports: “Microsoft GS Wavetable Synth”
  • 15:35:21.888 enumeratig TAPI Devices…
  • 15:35:21.888 found TAPI devices:
  • 15:35:21.891 enumeratig Audio Renderer Devices…
  • 15:35:21.913 found Audio Renderer Devices: “Lautsprecher / Kopfhörer (IDT H”,“Default DirectSound Device”,“Default WaveOut Device”,“DirectSound: Lautsprecher / Kopfhörer (IDT High Definition Audio CODEC)”
  • 15:35:21.913 enumeratig Midi Renderer Devices…
  • 15:35:21.915 found Midi Renderer Devices: “Default MidiOut Device”,“Microsoft GS Wavetable Synth”
  • 15:35:21.915 enumeratig External Renderer Devices…
  • 15:35:21.916 found External Renderer Devices:
  • 15:35:21.918 enumeratig Audio Input Devices…
  • 15:35:21.924 found Audio Input Devices: “Mikrofonarray (IDT High Definit”,“Dock-Mikrofon (IDT High Definit”,“Mikrofon / Line-In (IDT High De”,“Wiedergabeerfassung (IDT High D”
  • 15:35:21.924 enumeratig Video Input Devices…
  • 15:35:21.934 found Video Input Devices: “PS3Eye Camera”
  • 15:35:21.956 creating MainForm
  • 15:35:21.994 creating AddonHost
  • 15:35:22.610 vvvv caused error during startup: Die Datei oder Assembly “file:///C:\VVVV\vvvv_45beta27\lib\nodes\plugins\VVVV.Nodes.dll” oder eine Abhängigkeit davon wurde nicht gefunden. Der Vorgang wird nicht unterstützt. (Ausnahme von HRESULT: 0x80131515)

    but I checked - VVVV.Nodes.dll is there

hm, this is odd.
two questions:

  • how did you unzip the download? using an unzip-program or the windows built-in unzipper? and if the windows unzipper, did you use the “Extract here” option or did you just dragdrop the directory from the zip out?
  • if you rightclick->properties on VVVV.Nodes.dll on the very bottom do you see something like: “Security: This file came from another computer and might be blocked…”

@joreg:

  1. via WinZip: first directly to vvvv directory or I tried a nice place on my harddisk as well.
    2.YES - but very many (maybe all?) .dll in lib/nodes directory have this security flag

Is there a reason that the background color of renderer (svg), does not get saved when using writer (svg)?

@sune: please start a new thread for this question

@dimix: ok, our understanding was that those security flags only appear when you dragdrop the content of the .zip out from the windows built-in unzipper. but you say you used winzip and they also appeared.

anyway crack was supposed to remove them, which it does on my test-systems, but obviously not on yours for some reason. can you please check: in lib\core does VVVV.Hosting.dll also have this flag?

VVVV.Hosting.dll doesn’t have this flag

ouright, please try the new crack, attached

crack.zip (240.4 kB)

Hi joreg,

  1. new crack doesnt help.
  2. after I manually removed the security flag from VVVV.Nodes.dll, I am able to start beta27 and run some of old patches, but as I see the other uncracked .dll’s produce red nodes and crashes
  3. is there the way manually remove this security attribute from ALL files in the install directory?

so you replaced the original crack with this new one and ran it? thing is, that should actually remove the flag on all .dlls in any subdirectory. so if the addonpack is already in the directory when you run crack it will also remove the flag from all .dlls in the addonpack.

can you recheck, that after running the new crack from its original location still some of your .dlls have the flag set? i never get the flags to show up on any other files than the ones in \lib\core. no idea why windows chooses to flag those but not the ones in \lib\nodes\plugins.

spray and several nodes red???
resolved