Forum

Add trouble

i have a little problem with my Nvidia 460M:

i m blending videos on each others in add mode, wich works for fading them.
my laptop card is confgurated in full range 0-255, but i have this result:

Any idea on how to solve this ? ( images and videos are all black and white)

do some levels on post

hi anthokio, thanks but videos are generated by computer and i have checked: my black is a real black so this is more a problem of graphic cards than sources trouble.
i cant afford in time and ressources to level up or down all materials. this is really a weird thing.
when i output a single black video, i have this result:

the videos are generated by final cut and sony vegas on different machines, so i m pretty sure this is a setting things not ok.

Clearely i need help on that one !!!

ai karistouf,

so you’re sure you followed this: https://discourse.vvvv.org/ ?

ai joreg ! dead link … so difficult to follow it :-(
its filestreams

just from the top of my head: could this be some sort of gamma problem? (or colours/levels clipped to “tv safe” range on export)

edit: this seems to be the thread joreg mentioned:
https://discourse.vvvv.org/

edit2: lol, seems to be a forum encoding bug as the link has a space in it

https://discourse.vvvv.org/

yep founded, unfortunatly i m already full range 0-255 for my two monitors ( rendering and main patching)

about amma: this is yes a gamma issue if i insert a levels node as antokhio suggested, it will kill the grey effect. But my main problem is that all my patch is based on texture added on the top of each other. So i cant use levels because i have too many sources different to mix together.

so could it be that the gamma of your footage is not interpreted right by filestream?

does the footage look right when played by a standalone mediaplayer (e.g. vlc) on the target system?

yes. if i put the footage inside vegas, and make it little, i have a complete real black
this happens also on filetextures. i m working with a traditionnal cartoonist wich is producing its animation on black paper. So i dont have png with transparencies. its very strange.

There’s a good chance the problem stems from Vegas. When you stick a Quicktime file in it it raises the blacks to 16,16,16, if my memory serves me right… You could try a couple of things:

Use the newest versions of Quicktime on both machines

Convert the file type of the video using using MpegstreamClip from .mov to .avi. I use it for Mjpegs from time to time (What kind of files were they?)

Use Premiere Pro (meh…)

Actually re-render 'em (worst case scenario) to avi.

There might be other solutions but I’d have to look them up. Check out here for now: http://www.sonycreativesoftware.com/forums/ShowMessage.asp?ForumID=4&MessageID=690673

Hope it helps,

Hadasi

hi hadasi, yes this is helping a lot!

graphics are produced on MAC.

But usually i dont have such problems with vegas outputted files in VVVV, but it was with ATI. now i have this 460M. Sure its not hardware boosting gamma ?

so is there any chance to find a light solution just to get down quickly and ressourceless gama from textures ? ( a kind of gamma ultra light shader ?)

a kind of trick to get answer of graphic card on loading texture ?

Play a video and adjust the video settings in the nvidia control panel?

hi cat. well its not enough the gamma cheating in nvidia to obtain a real black.
The problem is not just the general output. The probleme is that each quad is interpreted with a higher level of black, and so adding multiple quads supposed to be black is a nightmare.

the problem persists also with dds textures coming from importation of drawings from a mac

yeah, the problem ist most definitely wrong gamma and or clipped “tv safe” colour ranges.

you should really have a close look on your source footage to find out more. (e.g. colorpick a “black” from it to get some insight on actual pixel values) also check all hardware settings like joreg and catweasel suggested.

edit: this is a classic mac <-> pc content pipeline problem which i encountered numerous times. (all because apple engineers picked the “wrong” gamma at some time in the 80s to make black and white output look right on the first laserwriter. doh…)

also see: http://en.wikipedia.org/wiki/Gamma_correction

ok. problem is that i m converting mov with vegas. so im dead on all the line.
dont have mony to buy a premiere where i have invested in sony. :-(
at the end my black are 17 value.
i will try to write a little shader just to cut down blacks with a threshold value.
many thanks !

seems like vegas defaults to studio rgb as default colorspace.

check these for further explanation/fix:

http://forum.doom9.org/showthread.php?t=159861
http://www.glennchan.info/articles/vegas/colorspaces/colorspaces.html
http://www.glennchan.info/articles/vegas/v8color/vegas-9-levels.htm

hi m4d, very interresting sources!

unfortunately ( arghhhh) my test file is not working as expected!

setted a black color on track 0 0 0 255
setted default export of project as 32 bits full range
tried with and without colorspace studi to rvb

same result.

test noir.zip (36.1 kB)

karistouf your videtexture going in to shader just tweak it there with levels…

sometimes the other video texture works better too maybe?

that is some really strange footage you pasted with the patch. it has a solid black (0,0,0,255) at frames 1 and 2 which turns into (1,1,1,255)at frame 3 and seems to stay there…