Forum

Add trouble

Ah ! Thats a good hint md4 holmes !
all videos i m exporting from vegas (mov -> wmv) are reacting the same

I will get some tries to fix it but i m still in doubt with my gfx card. Anybody could send me here a little pure black movie?

Antokhio: tomorrow i will male a little shader. I have a lot of textures, if its not a gfx card pb i will take this way. Levels is too heavy for a multiple usage ( around 50 sources, video and images, not spreaded )

here, this should work if your hardwaresettings are right.

video of solid black (0,0,0,255) (8.5 kB)

Hey nice find m4d.

Noticed something rather surprising. I usually encode in Motion Jpeg using ffdshow. I tried a trial of PICVIDEO and it rendered with the correct blacks (I checked in After Effects). Then I looked at all the other ffdshow Mjpegs and they looked okay too… PICVIDEO seems to have a friendly decoder that is correctly interpreting the levels. The decoder settings can be changed in ffdshow, but they haven’t made any difference yet. Try PICVIDEO.

hi m4d thanks a lot !
well its puzzlng: your video solid black react even worth when i m using blend !
add-> same result
blend -> worth resukt ( see image here). Does it react the same on your system ?https://vvvv.org/sites/default/files/imagecache/large/images/black%204d.jpg

hi adassi, so you think this is a codec problem, right ?

edit: mjpeg PIC video codec not showing up in vegas.
installed
Blend: all blacks i have generated ar showing like m4d’s black, in dark grey. So: a question of video card ? i will update my video driver and see whats happening.

no hope with drivers up to date.

i was thinking that Nvidia was a good flavour, recommanded by every body, well, seems next time i go back to ATI.

here is a little shader. It doesnt have unc’s elegance… ( religious thought to unc)

If someone see how to make it more light, it would be great. I m quite not sure to be obligated to decompose color in a vec4d:
c.r= c.g= and c.b=do_black_offset(c.b) instead of c=do_black_offset©;

anyway, many thanks for your help !!!

BlackOffset.fx (3.1 kB)

great everything ok ;]

to note (as previous post is flagged as solution)
this ‘grey but not black’ issue is a codec issue, not a GPU issue

more like decoder…

i was a bit puzzled to go to this extremity of shadering
So i continued after my post to search better solution.
in fact it was a driver issue, nvidia wasnt automatically reinstalled with newest driver by automatic update function ( azus package)
I forced download and install manually the driver from last nvidia release.
So the pb was a pb of driver, and asus utility update wich can be said really buggy!

Many thanks to you, dont know how many time i would have been kept in this problem without your help !

@karistouf: lol, it totally worked with the solid black video on my workstation at home. just imagine my surprise when i had the exact same problem like you on my box at work today… :o so elliot is right, i’d say.

edit: ahhh, haven’t read your last post. so never mind ;)

;-)

hehehe, luckily not really :D

was able to fix it with the settings from joregs 1st link. Actually it looks like old nv drivers had clamped color playback as default, while newer drivers seem to have full range enabled by default… ^^

ok happy to read it ! pfiou what a mess !
hopefully situation saved !

ok. my apologies!

What for elliot? To help and participate? ;-)
Great work you are doing !

yeah, what a mess indeed!

seconded! ;)