Xfile & reader does not read

see the attached .x file.

first; create an XFile node and open up the file in 33beta9.10
the Mesh output shows an empty set. that is wrong. only after connecting the xfile to an effect and an renderer it show the right output: a mesh with 11 subsets. why is it not showing the right data right away?

but this a cosmetic one - the following two are more serious:

second; if you look at the source of the xfile you will see various texture references. am i right that the TextureFileName pin is supposed to output a spread of these texture file names? it doesnt.

third; as we are regexpr experts here at meso hq, we tried to open up the xfile with the Reader node and tried to get our hands at the texture names ourselves. most of the time the reader does not really read our 101Kb textfile but stays empty. but i guess this is somehow a known bug.

and a cosmetic one

fourth; after we somehow manage to load the file, the tooltip shows pixel artifacts in the patch window. it somehow looks like that the full 101Kb are put into the textarea of the tooltip which starts to confuse poor old gdi?

ahem. x attached. (note that it is not supposed to show a full room, only some parts)

mahler.zip (6.0 kB)


ad f) that is by design. an xfile needs a device to be created which it only gets as soon as it is connected somehow to a renderer or other devicesink (like vertexbuffersplit). okok. we could create a dummydevice everytime needed as we do for the effects already…but …

ad s) right. i the texturefilenameoutput didn’t survive the big remake. log it as a bug.

ad t) known. so or similar. already on some lists…

ad f) hm. never noticed such a thing.

ad s) does somebody in particular think it can be logged as a bug which can be fixed real soon now? (like in till sunday?)

i am still not connected too good here. will have a look at it tonite and comment tomorrow. ah what day is it?

by the way. kinda fixed that for next release.