WithinViewport / 2D Rendering in Stride

I’m just trying to get some 2D Skia interface/text elements on top of a 3D Stride (Fuse) environment and I’m already failing. In beta, I used WithinViewport or WithinProjection. Can’t find something similar or a helppatch for that. What I have is the SkiaTexture rendered on a plane in 3D Space. I also tried to work the other way around: load the Stride texture into Skia but then colors are suddenly faded/darker despite always using the same 8bit SRgb for the TextureWriter that uses this texture.

Does anyone have a hint for me?

Have you tried SceneTexture and converting the Texture to the SKImage then? Never had a problem with that.

Also here are three tutorials that deal with this topic.

1 Like

Check out SkiaRenderer that comes with stride.


Thanks @bjoern and chk.

The Skia Renderer kinda worked for me but i thought that I don’t need to render the whole resolution and wanted to use transforms on the RenderEntity, which didn’t work. I was able to moove the box to the desired position in Skia though.

I’ve seen two of the mentioned videos. I don’t know why saturation/lightness changed when using TextureToImage instead of the TextureWriter for me. I assume some SRGB conversion stuff was going a bit wrong but all was set to R8G8B8A8_UNorm_SRgb.

Best, Andreas

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.