Wierd texture stuff

how to get rid of that wierd pattern thing happening in the background, i am scaling texture on shader

does anisotropic filtering help? if it does, do i have to incorporate it into shader?

looks like Moiré effect due to bad or none existing mipmaps. try creating DDS textures with mipmaps (Nvidia Photoshop Plugin, ATI Compressionator or DDS Converter)


can i produce dds from renderer? textures are actually made in another renderer and slightly animated

ok i found mipmap setting, after setting it to “all” its much better

If you use DX9, then DX9Texture (EX9.Texture) has a mipmap inlet. Is it of any use?

Ah, late. Sorry.

you incorporate anisotropic filtering by changing interpolation method in the samplerstate inside the shader. in dx11 you can have samplerstates as a pin and change sampling settings from the sampler node