Forum

Why Docking may not work?


#1

Hi!

I read this thread The user interface in detail#docking very carefully, but i still can not do tabs myself!

Make new patch, save it. Make other patch, save it in same folder. Drop second patch in root patch. Pressing and release ALT and mouse buttons carefully and many times. But nothing.

I saw tabs in other patches and i can use and undock them.
If i use same module several times in patch and open any copy (ALT+1), it opens in dock with other copies of that module.

Single difference with other world is language of XP. known problem with language is difference between dot and comma. Values in english XP are shown as 0.0000 but in russian are 0,0000.

really i guess i just miss something basic… help please


#2

docking works, you just have to get the order right:

it is not important where the patches are stored, just have some patches open.

then press the ALT key and click in an empty space of one patch (not the border or title bar) and drag it over another window. when dragging you see a gray frame border moving, which will snap into the other window when over it.

when you have docked the patch, resize the window a bit, so that the position and size settings of both windows are stored when you save them.

that should be it…


#3

yes it is. thank you tonfilm!

what difference between…

this (understand in 2 secs):

the most then press the ALT key and click in an empty space of one patch (not the border or title bar) and drag it over another window. when dragging you see a gray frame border moving, which will snap into the other window when over it.

and that (not understand in 2 days)

Dock one window to another by pressing ALT while clicking in a window and dragging it onto another. Release the mouse button when a gray border in the target window appears. Then use the tabs to bring different windows to front.

need to clear brains. thanks a lot again!


#4

what about renderers? can’t get them to dock together


#5

you can dock them with a trick:
open your patch with XMLmarker or Texteditor and set all BOUNDS attributes for both renderers to the same values.

should work also “on the fly” using Getpatch/Setpatch

<NODE nodename="Renderer (EX9)" componentmode="InAWindow" id="0">
   <BOUNDS type="Window" left="12420" top="8355" width="6120" height="4860">
   </BOUNDS>
   </NODE>

#6

thx… no text …