Forum

Weird behaviour with player (EX9.Texture) in boygroup

Hello
I have a weird behaviour of the player (EX9.Texture) in a boygroup setup:

What i want to do:
Play 5 Streams FullHD 60 fps dds stacks on 2 Machines connected via Boygroup.
The hardware should easily handle this, I tested it on way slower machines.

What doesn’t work
When I start vvvv as client, the fps drops to 15-20. Perfmeter is telling that the GPU is the bottleneck.

What works (in this exact order)

  • Start vvvv as client, patch runs at 15-20 fps, GPU is bottleneck
  • Close vvvv (client)
  • Start vvvv (not boygrouped) open the patch. Runs smoothly at 60 fps
  • Close vvvv (not boygrouped)
  • Start vvvv again as client. Voila: patch runs at 60 fps.

Everytime the computer is restarted, i have to do this procedure to get the patch running at 60 fps as client.
As I want to build a setup, that shuts down and starts up automatically, I would like to avoid this workaround.

GPU is AMD Radeon 7850, running as Eyefinity Group in 1920 x 5400 Px.
(http://www.jacob-computer.de/Grafikkarten/PCI/Club-3D-Radeon-HD-7850-Eyefinity-6-CGAX-7856M6-artnr-2026321.html)
But the problem appears too, if i dont use Eyefinity Group (5 x 1920 x 1080).

Seems to me like something has to be initialized on the gpu locally.
Did anyone have this problem? Or any hints how to solve this?

Thank you very much :-)

Cheers Gerrit

does your computer have two graphics cards like a laptop? sometimes the graphics driver uses the onboard graphics instead of the real GPU if you don’t tell it explicitly what to use…

No, i have only one.

hm…do you get anything in TTY, when it is slow?

This is what TTY says, but I think it doesnt relate to the problem, right?

00:00:04  -  : AsDesktop: 1920 x 5400
00:00:04 ERR : Corrupt link-message in Patch C:\WELCOME\patches\Welcome_V04\root.v4p. srcViewPin or dstViewPin is nil!
00:00:04 ERR : Corrupt link-message in Patch C:\WELCOME\patches\Welcome_V04\root.v4p. srcViewPin or dstViewPin is nil!
00:00:04 ERR : Corrupt link-message in Patch C:\WELCOME\patches\Welcome_V04\root.v4p. srcViewPin or dstViewPin is nil!
00:00:04     : Actual Timer Resolution: 1.0009
00:00:04  *  : can't draw whole geometry at once: * preprocessing vertices of any kind of billboards or onesided particles is not yet supported. World is camera dependent.switching to slicewise rendering.
00:00:04  *  : can't draw whole geometry at once: * preprocessing vertices of any kind of billboards or onesided particles is not yet supported. World is camera dependent.switching to slicewise rendering.
00:00:04  *  : can't draw whole geometry at once: * preprocessing vertices of any kind of billboards or onesided particles is not yet supported. World is camera dependent.switching to slicewise rendering.

I tested it on a different computer with the exact same hardware.
On that computer everything is fine.
Might be a hardware problem - Mabe the GPU is partly defective…