Vvvv-sdk and windows 8

in preparation of the node meeting i wanted to set up the vvvv-sdk on my notebook with windows 8 installed. unfortunately i stumbled into lots of errors when trying to compile the addon-pack (missing assemblies, …).

did anyone successfully install the sdk under windows 8?

here is what i did a little more precisely:

  • i followed the exact instructions how to install the addonpack
  • no .net 4 install nescessary under win 8
  • but i installed the windows 8 sdk
  • and i’m using sharp develop as ide

–> no success.

just to make sure i did not forget anything i followed the procedure on a win 7 computer without any problems.
any ideas?

hei motzi,

please pull upstream and try again. i suspect it was only the update-symlinks script which wasn’t yet checking for win8. hopefully fixed that. couldn’t try it myself. please report.

sorry, no luck after the update. i also checked out a clean version from vvvv/vvvv-sdk just to make sure.

i noticed the following:
windows 8 sdk also installs .net 4.5 (see also here under what’s new). when opening the .sln in sharp develop among all the other stuff it complains about this

The reference assemblies for framework “.NETFramework,Version=v4.0” were not found. To resolve this, install the SDK or Targeting Pack for this framework version or retarget your application to a version of the framework for which you have the SDK or Targeting Pack installed. Note that assemblies will be resolved from the Global Assembly Cache (GAC) and will be used in place of reference assemblies. Therefore your assembly may not be correctly targeted for the framework you intend.

i attached the whole output - maybe this helps finding the bugger. if i can do anything else please let me know.

sharpdevelop_output.txt (184.5 kB)

is .net 4.0 installed? if not get it. you need the correct platform in order to compile…

.net 4 is already part of windows 8. if you try to install, the setup program does not allow you to because of this.

not entirely correct: .net 4.5 is part of the windows installation, as stated here:

Windows 8 and Windows Server 2012 include the .NET Framework 4.5, so you do not have to install it separately on those operating systems

its not clear to me what that means. are you aware of the fact the .net 4.5 and .net 4.0 are different things? 4.5 does not include the binaries of 4.0, so you need it as a separate installer. or do you mean, that win8 does not allow you to install 4.0?

after some googleing i found out that i can change the target framework from 4.0 to 4.5. i did this by choosing (on the solution): properties->compiling tab ->target framework

still, this does not solve the problem, but the output is a little different now (see attached file).

btw: sharpdevelop throws an exception when trying to change the target framework of the Timeliner because of a missing file. but this is probably a sharp develop issue

sharpdevelop_output2.txt (13.5 kB)

wait… instead of porting vvvv to 4.5 you just have to install 4.0… or do i misunderstand something here? why do you want to use 4.5 so badly?

it’s not that i’m so keen on 4.5. but 4.5 is shipped with windows 8 and part of the OS. the installer of 4.0 simply does not allow me to install itself because a higher available version…

ah, i just noticed that i missed your post from 00:17. yeah - that’s exactly the problem.

also, from what i read yesterday online i assumed that 4.5 is backwards compatible to 4.0

motzi: there was a problem with my “fix” mentioned above. please try again now.

sorry joreg, no luck still (same assembly-missing errors, checked with a fresh pull from vvvv/vvvv-sdk. tried with plain solution and also changed target to 4.5).
any debug-info i can provide?

make sure you set the active build platform in sharp develop to x86 (Build -> Set platform -> x86). also make sure that the folder vvvv45/addonpack/src/thirdparty exists. this one is a symbolic link and should have been setup by the init script.

well, it seems a fresh pull really fixed it now. thank you for your support!