Forum

Vvvv in WinOnX (Wine)


#21

I use Linux at my job place everyday. It is a great OS, but, if a software is not supported (for example After Effects, Reactor, Reason) it can be very difficult to make it working. On the other side, on Windows you can just run it with a click.

Vice versa there is software that works great on Linux and it is hard to use on Windows (for example Node.js one year ago,a lot of Unix libs and command line tools).

Maybe you can try a dual boot so you can use Linux all the time and switch to Windows when you want to use vvvv.


#22

To register AddFlow I use the command:
regsvr32 “C:\Program Files\vvvv_45beta28.1\lib\thirdparty\AddFlow3.ocx”

After a few seconds I get the error:
Failed to load DLL C:\Program Files\vvvv_45beta28.1\lib\thirdparty\AddFlow3.ocx
The command returns 1.

I’m not sure if CrossOver is not able to find the ocx file or if it can’t register it because it is not a dll file. I’ve installed v4 in a Win XP bottle.

Well, to work seriously with v4 it is better to use Windows. Better performance, better workflow etc. But I think it would be an interesting option to use Wine to run v4 if you’re on a Mac and if you just want to play a little with it. The biggest issue why I don’t work with v4 is that it is not running on OS X.


#23

strange error message…but still: try to load AddFlow3.ocx with dependecy walker: http://www.dependencywalker.com/ it maybe reveals a missing dependency.

alternatively try with latest alpha-build, which is using AddFlow5.ocx and may behave differently.


#24

Thanks joreg, I downloaded and started dependencywalker and found out that the DLL mfc42.dll was missing. I downloaded an installer from DLL-files.com which installed and registered the missing dll. All boxes of crack.exe are green now. Actually I’m stuck at the same point as elliotwoods, v4 starts with the splash screen and hungs up. Seems like there’s no way to get v4 running in Wine. Anyway, thanks for the support.


#25

so you did logstartup and it also hangs at “creating Gex9Base”?


#26

Thanks for the hint, joreg. Actually I get an OLE error:

[11:25:06.572](11:25:06.572) everything you know is wrong
[11:25:06.579](11:25:06.579) creating SplashScreen
[11:25:06.643](11:25:06.643) Adding lib\thirdparty to PATH.
[11:25:06.644](11:25:06.644) creating GClock
[11:25:06.691](11:25:06.691) creating GMainloop
[11:25:06.692](11:25:06.692) creating GLog
[11:25:06.693](11:25:06.693) creating GApplication
[11:25:06.694](11:25:06.694) creating GGlobals
[11:25:06.695](11:25:06.695) creating GNodeFactory
[11:25:06.696](11:25:06.696) creating Gex9Base
[11:25:07.722](11:25:07.722) Direct3D9 initialized.
[11:25:08.004](11:25:08.004) ExceptionDialog is disabled. Start vvvv with /showexceptions to enable it.
[11:25:08.403](11:25:08.403) enumeratig Game Devices...
[11:25:08.444](11:25:08.444) found Game Devices: 
[11:25:08.445](11:25:08.445) enumerating Midi Input Ports...
[11:25:09.997](11:25:09.997) found Midi Input Ports: 
[11:25:09.998](11:25:09.998) enumerating Midi Output Ports...
[11:25:09.999](11:25:09.999) found Midi Output Ports: "CoreAudio MIDI Synth 0"
[11:25:10.005](11:25:10.005) enumeratig TAPI Devices...
[11:25:10.006](11:25:10.006) found TAPI devices: 
[11:25:10.012](11:25:10.012) enumeratig Audio Renderer Devices...
[11:25:10.025](11:25:10.025) found Audio Renderer Devices: "Built-in Output","DirectSound: Built-in Output","DirectSound: Display Audio","DirectSound: Out: Default Device","Display Audio","Out: Default Device"
[11:25:10.026](11:25:10.026) enumeratig Midi Renderer Devices...
[11:25:10.028](11:25:10.028) found Midi Renderer Devices: "CoreAudio MIDI Synth 0"
[11:25:10.029](11:25:10.029) enumeratig External Renderer Devices...
[11:25:10.030](11:25:10.030) found External Renderer Devices: 
[11:25:10.033](11:25:10.033) enumeratig Audio Input Devices...
[11:25:10.035](11:25:10.035) found Audio Input Devices: "Built-in Input","Built-in Microphone","Display Audio","In: Default Device","MicrosoftÆ LifeCam Cinema(TM)"
[11:25:10.037](11:25:10.037) enumeratig Video Input Devices...
[11:25:10.038](11:25:10.038) found Video Input Devices: 
[11:25:10.072](11:25:10.072) creating MainForm
[11:25:10.098](11:25:10.098) creating AddonHost
[11:25:10.101](11:25:10.101) vvvv caused error during startup: OLE error 80004005

Any ideas?


#27

uk. please try with latest alpha. that should pop up an error dialog. and you could post the error here.


#28

Ok, the error dialog shows:

There was an error during the execution of this program.
The application might become unstable and even useless.
It's recommended that you save your work and close this application.

OLE error 80004005.

A strange thing is, when I run crack.exe of the newest alpha, it says that Visual C++ Runtime 2008 is missing. After downloading and installing it with click on the WebSetup button, the box is still red.


#29

uk, that doesn’t help…
next step for you could be to checkout the vvvv sdk and debug this yourself. ie. set a breakpoint on startup and see where it fukcs.

strange also with the crack…is that even after restarting it? i just pushed a minor modification to the crack, see latest alpha. but i kinda doubt it fixes that issue…


#30

I tried the new alpha, same problem.

I googled about the OLE error 80004005 and found a Microsoft paper (german) which explains that it could be a permission problem trying to access a registry key:

http://support.microsoft.com/kb/238971

Really don’t know if this has anything to do with the problem I have. Also I could not test it because I don’t know how to change permissions of a registry key in CrossOver. When I run regedit I can’t find a menu to set the permissions of a key.


#31

ja, i don’t think this is related. really the net thing to do would be to debug this…


#32

Alright, thanks for the support. I let you know if I get ahead with this project.


#33

any news ?


#34

I’m currently trying the same thing using Crossover 13.
I get past the DirectX intilization but get an exception at this point.
Any idea how to fix that?

07:24:14.767 creating AddonHost

07:24:16.660 vvvv caused error during startup: The composition produced a single composition error. The root cause is provided below. Review the CompositionException.Errors property for more detailed information.

  1. External component has thrown an exception.

Resulting in: An exception occurred while trying to create an instance of type ‘VVVV.Nodes.Kommunikator.KommunikatorPluginNode’.

Resulting in: Cannot activate part ‘VVVV.Nodes.Kommunikator.KommunikatorPluginNode’.

Element: VVVV.Nodes.Kommunikator.KommunikatorPluginNode --> VVVV.Nodes.Kommunikator.KommunikatorPluginNode --> TypeCatalog (Types=‘VVVV.Nodes.Kommunikator.KommunikatorPluginNode’).

Resulting in: Cannot get export ‘VVVV.Nodes.Kommunikator.KommunikatorPluginNode (ContractName=“VVVV.PluginInterfaces.V1.IPluginBase”)’ from part ‘VVVV.Nodes.Kommunikator.KommunikatorPluginNode’.

Element: VVVV.Nodes.Kommunikator.KommunikatorPluginNode (ContractName=“VVVV.PluginInterfaces.V1.IPluginBase”) --> VVVV.Nodes.Kommunikator.KommunikatorPluginNode --> TypeCatalog (Types=‘VVVV.Nodes.Kommunikator.KommunikatorPluginNode’).

Resulting in: Cannot set import ‘VVVV.Hosting.IO.PluginContainer.PluginBase (ContractName=“VVVV.PluginInterfaces.V1.IPluginBase”)’ on part ‘VVVV.Hosting.IO.PluginContainer’.

Element: VVVV.Hosting.IO.PluginContainer.PluginBase (ContractName=“VVVV.PluginInterfaces.V1.IPluginBase”) --> VVVV.Hosting.IO.PluginContainer


#35

I tried this again in Crossover 15 / Wine 1.8 under Ubuntu 15.04. Everything works pretty flawlessly, except for the DX9 renderer, unfortunately, which exits with an exception. Apart from that I haven’t found a node that crashes or misbehaves so far. Audio works fine.
Performance is also very good so far.

Here is a screenshot with the GDI renderer running.
HTML renderer is also working perfectly.

I also attached 3 exception logs from when I opened the DX9 renderer, aswell as the TTY output and a startup log. Maybe this error can be fixed by the devs? It doesn’t sound like a major issue. Seems like it has some allocation issues.

If someone is interested in the Crossover bottle, just say so and I see if I can upload it somewhere.

TTY output when opening the DX9 renderer. (1.6 kB)
Startup log (1.8 kB)
First exception (14.6 kB)
Second exception (14.0 kB)
Third exception. After that it repeated once and stopped trying. (13.5 kB)


#36

hei Timonski,

thanks for your report. regarding DX9 the errors still show that there is a very basic problem with the dx9-device even if startup-log says it is initialized…weird.

i assume you tried this with b34.2?! in order to easier debug this: can you also try this with latest alphas? there may be different problems showing up due to it relying on .net46. if not that would be nice because for alphas we could much easier provide you with little fixes to the specific errors you got. see?


#37

Yes, I tried beta 34.2

I tried what I could to get .NET 4.6 running but had no luck so far, all the available installers are failing. Maybe I can install it differently but right now I can’t test the latest alpha because of that :/


#38

@Joreg, what is stopping vvvv using Mono libraries instead of .NET in future alphas?


#39

Guest, what is your opinion about the future of Mono now that .NET Core is open source? Could that awesome project somehow be overtaken by the MS’s initiative?


#40

@guest: i am not sure if that is an actual option to “just” do that and then expect it to work on wine. and we don’t have the resources here to investigate this…