Forum

Vvvv in WinOnX (Wine)


#41

@h99, they seem to be working in partnership. MS has probably already tried to buy them because they like certain parts of mono’s tool chain (the phone-friendly bits), but Mono have a foot in the Linux realm and to there credit they’ve built a business that sustains the development of Mono. Still, I’m no expert.

Its a bit strange to think there will effectively be 2 .NETs out there, capable of running of lots of different systems. At that time I think people will side with MS, but who knows what the future holds.

As long a .NET developers can envisage making apps beyond Windows and they can stay inside the MS eco-system. they’ll be happy to assist them, for now. OS X/Linux .NET sounds good from a vvvv point of view too.

@Joreg, okay, I wouldn’t know what goes into it, but the impression I have is that the gap between the two libraries has closed significantly that it could be possible to test it, but I don’t understand the ins-and-outs.

But just imagine how happy designers would be to have vvvv running with Syphon? ;-)


#42

I’m no expert, too. And I too agree that “Its a bit strange to think there will effectively be 2 .NETs out there”.
The fact that the partnership is older than the late 2014 c# open-sourcing announcement should then change an observer’s point of view: immho MS, under the guidance of Nadella, realized, yet very late, how their model market was changing and how it changed forever; this may not be a matter of life or death to MS, but open source c#, for a company like MS, it’s a choice that closely resembles it, or, probably better, that makes me think that drastic measures had to and will be taken.


#43

Welp, that settles it:


#44

Imho, that, or something that could have similar consequences, was quite predictable.


#45

Also: http://blog.dustinkirkland.com/2016/03/ubuntu-on-windows.html
Just saying…


#46

Hi Timonski
Have you checked winetricks?


Maybe that’s the way to run full vvvv. It should install dx9, dx11, net, etc. on Wine. Can’t check myself, no ubuntu around right now…


#47

Hi rogalag,
I’m actually using Crossover, which is like a premium version of winetricks. I don’t think that winetricks is doing anything better in that regard. Crossover is already optimizing a lot of that stuff like DirectX and adding workarounds to get things working that don’t normally work out of the box.

But feel free to try it out, I would be interested if it has different results.


#48

I managed to install .net 4.6.1 by extracting the exe and running the contained msi for installing the full package.

Though it did not solve the problem. The attached exception gets thrown when launching vvvv.

exception log (9.8 kB)


#49

that’s where it tries to instantiate
\lib\core\VVVV.Hosting.dll

i guess the file is there?

can you make sure that any other .net app runs correctly?


#50

Sorry for the late reply. I’m back at it now.
There was no other application running in the bottle.

I created a new bottle, now with the latest crossover version with 64bit support and using 50beta35 both in x86 and x64.
All the dependencies are installed, though vvvv is stalled at the splashscreen. No exception thrown this time. The startup log is showing this:
edit: Running with /showexceptions gives me the following exception:

2016.12.25-01.26.34.log (1.7 KB)
vvvv.exe-exception-2016-12-25.log (12.2 KB)

The 64bit version has a different error but that might has to do with the still not very stable 64bit support of wine.
2016.12.25-01.37.22.log (1.8 KB)
backtrace.log (29.7 KB)


#51

all those errors are related to the .NET framework. what version is wine running? try to update the .NET framework to the latest one that is possible on wine.


#52

@Timonski heyy please upload your bottle somewhere. i don’t need dx9 at all so i think it would be perfect.


#53

Unfortunately I don’t have the bottle anymore.
I tried again today. Installing all the dependencies works fine nowadays but it still does not want to work.

Running the latest 64bit alpha 35.18 (925bcd9949) I get until “creating AddonHost” and then it just idles forever.
Same for the latest beta. Running the x86 version causes a crash about not finding a method.
“vvvv caused error during startup: Attempted to access a missing method.”

@tonfilm
maybe you could add some more logging for that step in a coming alpha? :)


#54

Go with VMware


#55

What would be the point of a vm?


#56

Yea a VM really misses the point here. Wine is all about not emulating anything.


#57

Sorry guys, stupid post from my end.
I confused Wine with virtualbox, this is a complete different story, I’m quite amazed that its working on linux


#58

Tried it out today with lutris and dxvk as Steam is having a lot of success with that. Unfortunately the outcome is still the same, vvvv crashes silently at ‘Ccreating AddonHost’.
Would be great if I could in any way debug this further. Some more information on how and why it quit would be very valuable to know.

[18:41:48.846] everything you know is wrong
[18:41:48.846] Adding lib\thirdparty\x64 to PATH.
[18:41:48.895] creating SplashScreen
[18:41:48.900] creating GClock
[18:41:48.900] creating GMainloop
[18:41:48.900] creating GLog
[18:41:48.900] creating GApplication
[18:41:48.901] creating GGlobals
[18:41:48.901] creating device listener
[18:41:48.901] creating HID device controller
[18:41:48.909] creating GNodeFactory
[18:41:48.909] creating Gex9Base
[18:41:49.023] Direct3D9 initialized.
[18:41:49.046] ExceptionDialog is enabled.
[18:41:49.118] enumeratig Game Devices...
[18:41:49.120] found Game Devices: 
[18:41:49.120] enumerating Midi Input Ports...
[18:41:49.123] found Midi Input Ports: "Midi Through Port-0"
[18:41:49.124] enumerating Midi Output Ports...
[18:41:49.124] found Midi Output Ports: "Midi Through Port-0"
[18:41:49.133] enumeratig TAPI Devices...
[18:41:49.133] found TAPI devices: 
[18:41:49.135] enumeratig Audio Renderer Devices...
[18:41:49.139] found Audio Renderer Devices: "Built-in Audio Analog Stereo","Default DirectSound Device","Default WaveOut Device","DirectSound: Built-in Audio Analog Stereo","DirectSound: Pulseaudio",Pulseaudio
[18:41:49.140] enumeratig Midi Renderer Devices...
[18:41:49.140] found Midi Renderer Devices: 
[18:41:49.140] enumeratig External Renderer Devices...
[18:41:49.141] found External Renderer Devices: 
[18:41:49.142] enumeratig Audio Input Devices...
[18:41:49.145] found Audio Input Devices: "Built-in Audio Analog Stereo","Monitor of Built-in Audio Analo",Pulseaudio
[18:41:49.145] enumeratig Video Input Devices...
[18:41:49.259] found Video Input Devices: video0
[18:41:49.285] creating MainForm
[18:41:49.316] creating AddonHost

#59

I got this Exception through the wine log. Maybe that is more helpful for someone:

Unhandled Exception:
System.Runtime.InteropServices.MarshalDirectiveException: [MarshalAs] attribute required to marshal arrays to managed code.
[ERROR] FATAL UNHANDLED EXCEPTION: System.Runtime.InteropServices.MarshalDirectiveException: [MarshalAs] attribute required to marshal arrays to managed code.

@tonfilm any idea what that could be cause by?

full log (the fixme messages shouldn’t matter much)
wine.log (2.4 KB)


#60

wait. so did someone get v4 running on linux using wine?