Vvvv doesnt run?

hi - im very new to vvvv…

downloaded vvvv and tried to run… theres only that DXRenderOut window - but thers no PATCH window :(

deleting ARGS.txt and re-run vvvv nothing happens. it opens and appears in my taskbar and if i click to minimize vvvv a small window from somewhere at my screen appears and minimizes to my taskbar… all video screens, directx-output windows are visible if i start a patch. herr inspektor is visible too - only patch window is invisible…

any suggestions how to fix that problem?

thanx ahead


-try to left click on the renderer and after do alt-R (make appear Root)
-be careful dual screen mode


hi thiv,

tried - but always the same - no patch window…

have also disabled 2nd screen - same result.

any other solutions?


>if i click to minimize vvvv a small window from somewhere at my screen appears and minimizes to my taskbar
when all patch are hidden it’s normal.

uninstall and try to install previous versions.
Maybe the problem come from your Windows configuration.

no more ideas… :(

do you have administration rights on your machine?

tried older versions of vvvv - unfortunately same problem. what kind of WINDOWS CONFIGURATION could hide program-windows? if directx and “herr inspektor”-windows doesnt appear- then ok. but these 2 windows are visible… so the problem MUST be a bug in vvvv, isnt? or am i wrong?

i have administration rights on my machine.

please - does anyone have another idea for my problem?

thanks ahead

Do you use a laptop?

no - no laptop. standard p4 2,8 HT - winxp sp2 - 2gb ram - directx9c - nothing special hardware.

note that vvvv will quit itself when an instance of vvvv is already running. under some occasion a crashed vvvv may reside in memory and will not allow you to start a new one. use the task manager to quit vvvv.

apart from that: we had some problems with old midi drivers keeping vvvv from starting when the interface is not connected. are your multimedia drivers all up and running?

i have no midi device installed on this machine… display- and multimedia.driver are up to date…

does vvvv use JAVA in any way?

i recogniced some java problems during surfing…

i had this problem twice at a friend´s pc when i wanted to show vvvv on a visit. it happened right after installing and i had no clue why this strange behaviour would take place on that machine. on my computers all the 4v does it´s work, but it seems not on every pc to do so.

dumb question: have u tried to unzip it to another location after having rebooted?

do you probably try to start vvvv.exe from a zipped folder? winxp has that function that lets you use .zip files as ordinary folders. but you can’t start vvvv.exe from such a temporary .zip-folder. extract first and then try again.

ya. and administrator rights are important!

mhhh - vvvv-directory waslocated at desktop - at first it came to my mind, maybe thats the problem. but it wasnt - after moving (and re-“installing”) to c:\vvvv the same problem appears…

hehe - and yes - i unzipped the whole archive ;)

strange, that this happens with ALL vvvv-releases… middle-clicking @ herr inspektor and set “show root” doesnt chnage anything :(

another strange thing is, that in taskbar that window is called like “ÅÅÅÅÅ” or “ËËËËË” - everything not in my native charset…

nkay. so this is really strange. since the program seems to start (you get renderer and inspektor) the problem seems to be coming from an extra activex control that vvvv tries to register on startup. the AddFlow3.ocx file you can find in the \bin folder. if it cant be registered you won’t see any patches.

you could try to manually install it and see if that succeeds. open a command prompt and navigate to the \bin path of your vvvv directory. there type:
regsvr32 AddFlow3.ocx

now what does that respond?

thanks for response.

trying your way, i get following error code:

DllRegisterServer in AddFlow3.ocx failed
ErrorCode: 0x80040201

nkay. so here we have the troublemaker. still… no idea what that could be…

cant find any hints about that error on the internet. if you are familiar with the registry (regedit) you could try searching for all entries conaining “AddFlow” and remove them. do this on your own risk! nothing much should happen though. could be that you have another software installed that uses the same AddFlow3.ocx control which could suffer from such an operation. highly unlikely though.

after you’ve removed all the entries just start vvvv.exe again.
and let us know. good luck.

regedit founds many “addflow” entrys
deleted every

but i cant delete these entries:

any hints?

3dsmax 8 uses addflow4.ocx (based at installdir) - deleting this - nothing happens in vvvv

trying to install addflow3.ocx from \bin causes old problem…

so very strange.
i don’t really think that this is the problem…but if you had the time to uninstall 3dsmax and really try to get rid of all the AddFlow entries in the registry.

you see i’m kinda outa ideas concerning that error.


uninstalling max8 and removing nearly every entry from the registry doesnt change anything.

i still cant delete
where a hint to addflow 4 (!) is based…

ok - seems i have to say “good bye” to vvvv.
its a pity but i have to face the truth…

thanks for all your hints

ok - seems i have to say “good bye” to vvvv.
its a pity but i have to face the truth…

you could reinstall windows.