Forum

Vvvv crashes while using library

Hi, I try to use the Markov chain library in vvvv gamma (just for fun). However, while I following the example from here I’m able to create Markov Chain instance I can’t call Add method. While I try to create Add node whole vvvv crashes. Can’t find the logs, checked settings xml — no debug option. Any thoughts?

I recompiled library to .Net Standard, didn’t help. Checked src — looks like the Add method has a lot of overloads, which not seen by vvvv. I tried to reduce overloads amount to 3 (without breaking API) — still crashing.

The interesting fact — if you create a class node, there you can access Add method without crashing whole vvvv. But no, you can’t.

Update: It works if you forward MarkovChain class by hands.

I haven’t come across an error like this is a while.
For the devs, the type that the functions supports isn’t visible in the Node Browser, so I copied them up here:


image
image
image
image
image
As Alg mentions, the gamma itself crashes (stays open in the Task Manager). Recreated by install the Markov Nuget and dropping an Add<MarkovChain> Node anywhere. The problem seems to be with IEquitable type it can’t include which probably needs a wrapper…
@Alg there have been a handful of types that have caused issues with Gamma. Using these nodes in Beta gets you this error:
image
though it doesn’t crash: different backend

Thanks for details, as i mentioned, looks like if you forward MarkovChain class via ctrl+shift+j menu all start magically work. You can create Add node with different input pis (overloads), so overload is not an issue. Probably an output type or something deeper which i can’t investigate due the closed sources and no crash logs at all.

If you start vvvv gamma with the --debug command line option and attach a Visual Studio debugger, you may get some extra detail.

Even though it is unlikely as there is no exception thrown.

There is no exception, you can test it yourself. Ok, will try --debug option.

UPD: Here is my implementation https://www.nuget.org/packages/VL.Markov/, worked only after class forwarding.

1 Like

Thanks for the report. Will be fixed in upcoming 2020.1.1 release.