VLC in DX9 not working

I have recently tried to use VLC with DX9 and it didn’t work. I have tried on different systems, all win10x64 and Beta34.2 with no luck.

am I alone with this issue?


EDIT: on both machines the versions of vvvv are x64

Just tested, and I’m getting a red node on 34.2 x64 in Windows 10 as well.

It works fine on 34.2 x86 though.

has it worked in previous vvvv x64 versions? if so in which?

I tested with 34.1, 33.7 and 33.1 and I couldn’t get it to work with any of them.

Sunep, can you corroborate this?

hm…just tested on win10x64 and works for me in b33.7 and b34.2 x64. so probably related to your vlc installation?

Which version of VLC are you using @joreg

it says 2.1.5

mine is 2.2.1… perhaps something broke in the meantime.

I am however leaning towards it being my windows install that is weird. I Need to find the best time to reinstall it.

fresh windows, other stuff behaves better now, but still no luck with VLC on x64.

here is what tty say when I make a Filstream (EX9.Texture VLC)

FilestreamVLC.txt (2.7 kB)

I reckon I’ve solved it. I went and downloaded the x64 version of 2.1.5 so I could see if it’d work with the same version joreg uses. It did, and the thought occurred to me that when I installed vlc ages ago I might have absently installed the 32bit version, since it’s the primary download link on the site. I upgraded to the latest 64bit version and everything works fine.

Perplexingly, 32bit vlc seems to have been fine with 64bit VVVV, unlike the dx9 version. Was a bit of a red herring.

Of course, now dx9 vlc doesn’t work in 32bit…