Forum

VL TCPSocket Bug

Seems like sender doesn’t work. In some cases something goes through but I couldn’t catch it.
I tried different nodes and approaches and got the same result

tcptest.zip (7.2 KB)

Strange, reconnected recevier node and it began to work.
But anyway it has a lot of strange behaviour. I try to connect this to another application and this, unlike the standard VVVV node, does not work correctly

Is it bug or am I doing something wrong? TCP connects only when any reciever/sender nodes connected and only last connected working — only send or recieve.

most likely this is a bug. please note that the tcp nodes in vl are still marked as experimental, meaning they have known problems.

do you absolutely need TCP or can you also use another protocol for your application?

@joreg Thanks! I’m very interesting in “observable” version of TCP, it’s mostly experiments as it marked) But I think it can be applicable in one real case.

I need TCP, sockets in more wide meaning.

if you can define the means of communication typically it is easier to work with something more highlevel, like VL.IO.NetMQ or VL.Mqtt.

@joreg thanks, it’s interesting, but I need pure tcp. And I tried mqtt, it’s works perfect.
I need it to write app for communucation with api of other app with tcp. It’s experiments but I don’t want to use default tcp nodes, want to use observable version for message processing.

i’m afraid, if you need it NOW, we cannot help you. but definitely in the future we’ll add proper TCP support.

if c# is an option for you, it is probably not too hard to get something working by starting here: https://vvvv.gitbooks.io/the-gray-book/content/en/reference/libraries/writing-nodes.html

@joreg I will follow the updates, thanks