Forum

VL.Firmata

Hi, I played around with the new LattePandaAlpha864 and Gamma but got stuck.

Windows Device Manager sees the ComPort ArduinoLeonardo and Windows10 FirmataTestApp works also 45beta34.2_x64 with node “Arduino(Device StandardFirmata 2.x)” connects and reads, sends data and says Firmware StandardFirmata 2.5.ino.

VL.IO.Firmata cannot connect - pin “Frimata Ready” is never true, pin “Firmware Version” always empty - I tried also change RTS enable in “PortProvider” because I read in another post that the Arduino ATmega32U4 would need this but I also read in another post that VL.IO.Firmata and old LattePanda (which has also an ATmega32U4) should work together like a charm. - so what I missed or what can I do in Gamma to go further? It seems like the Output of “PortProvider” is not correct and Port is open.

Greets
CeeYaa

Hi CeeYaa,

confirmed, VL.IO.Firmata is broken in the alphas and the Tokenizer nodes are not working properly at the moment. We are on it.

Best,
Anton

thx for reply and fast fix

since vvvv gamma 2019.1 preview 252 - everything works like a charm
now firmata-gamma-play can start

greetings CeeYaa

Sorry, I was too fast with saying everything works here like a charm
Now I get feedback from FirmataDeviceNode that it gets connected and recognizes a Arduino with Firmata but I have problems to send signals for example servo
again old Firmata works in 45beta34.2_x64 like a charm but no movement of the servo when I try it in VL.Firmata vvvv_50beta38.1_x64, actual vvvv_50alpha38.2_x64 and gamma.

Greets
CeeYaa

Hi @CeeYaa,

yes, you were too fast or we were too slow. The fix you’ve seen was only for the part of the problem.
Today Firmata was fixed and passed the demos from the HelpBrowser, incl. servo.
Would you please test it on your side?

Best,
Anton

Hi Anton

testsetup:
LattePanda with intern Arduino(Leonardo)
LattePanda with externUSB Arduino(Uno)
LattePanda with externUSB Arduino(Duemilanova)
all the same StandardFirmata
Test: Servo Pin9

samePC sameVVVV or sameGAMMA

old Firmata works in 45beta34.2_x64 on all 3 Arduinos (HelpPatch ArduinoDevice)

VL.Firmata works in gamma0287 (HelpBrowser Servo) on Arduino(Uno) and Ardunio(Duemilanova) but not with the important intern Ardunio(Leonardo) (ATmega32U4) also the old LattePanda has

VL.Firmata gamma0287 detects StandardFirmata and get connected with Ardunio(Leonardo) (ATmega32U4) but cannot influence the servo when I change the inputvalue

STRANGE

hmmm???, greets CeeYaa

btw.: Leonardo died 500years and 4days ago and he won’t be happy ;)
I can send you some screenshots or you say which are the important pins or toggles in VL I should stumble through - I have not a clear idea what is happining in the VL.Firmata patches

Hi @CeeYaa,

thank you for providing us with your LattePanda Delta board.
It looks like that there is something special about the Leonardo and it’s overloaded AnalogIn pins sitting on top of the PWM pins, see this picture.

The Leonardo documentation on the Arduino website says, that the Leonardo board has only 20 pins, but the StandardFirmata reports all of its real 30 pins. It looks that we run into a problem when PWM pins are overloaded with Analog In pins.

The older Firmata Node (from 45beta34.2_x64) partly works because it defines a spread for only 20 pins. If you try to set some other pins (other then the 9th) to PWM and try to drive it, it fails as well.

I’ve tried the official LattePanda’s Firmata Example in VisualStudio and couldn’t drive some PWM pins. I’ve filled them an issue. Let’s see what they say.

As for now for driving Servos from the LattePanda Delta board use these pins: D3, D5, D11, D13. These are not overloaded by Analog pins.

Best,
Anton

THX Anton for the finding

so, seems now VL.Firmata Bug is solved after gamma0287 : Tokenizer and PortProvider Probs
the rest is a LattePandaPin Problem with StandardFirmata.ino

I will post here if something will happen with this issues, now I’ll take your advice and have a look at the LattePanda Appendix and improvise with the pins

thank you
Greets,
CeeYaa