VL art-net not working?

Yesterday I tried getting the nice and spreadable VL- art-net nodes to work, but failed, even in the most simple setup, just sending one universe.

Am I doing something wrong or is it broken in the current alpha?

is the helppatch working for you?

nope, nothing coming through.

it data is being received and lots of varying data goes into ArtNetDecoder but it is just zeroes coming out.

When I try to make the old DMX (Network Artnet Receiver) I can select it in the node list, but when clicking it nothing appears. If I then save and reopen, it might be there.

i mean if you open both helppatches for sender and receiver. do they communicate? make sure to try with latest alpha (i fixed a bugger there yesterday).

works in latest alpha… nice!

I did test with the helppatches, also with the slightly older alpha

but this still doesn’t work:

  1. Open an empty patch
  2. create ArtNet (Network Sender)
  3. open it’s help patch
  4. delete the first ArtNet (Network Sender)
  5. open the help patch of the ArtNet (Network Receiver) at the bottom of ArtNet (Network Sender)s helpfile
  6. try to create a DMX (Network Artnet Receiver) or DMX (Network Artnet Sender) in the empty patch I can’t create that one

do you get a “cannot bind socket error”? if so that is because there is another artnetsender already open with the same port…

yes I do get that error, but shouldn’t the node be made?

and I get the same error creating a DMX (Network Artnet Receiver) or DMX (Network Artnet Sender) and no node, shouldn’t there be a node, perhaps a red node, but a node

when creating the VL versions of the receivers, I get multiple receivers, but only the first one receives the data but I do get multiple nodes

it seems like there is an invisible node, tty goes crazy

a bit more info.

try this

  1. start vvvv with an empty patch with /allowmultiple
  2. make a DMX (Network Artnet Sender)
  3. make new empty patch in new instance of vvvv with /allowmultiple
  4. make a DMX (Network Artnet Receiver) - it fails on my setup with the cannot bind to port error

If I do the above just with two patches in the same instance, it works as expected, which also explains why the help patches work.

please check latest alpha for a fix on not being able to create the DMX () nodes when their port is already in use. they can now be created and show as red as long as the port is blocked.

Now I can make the node in the second instance, but it does not get red.

but I don’t understand why I can’t make a DMX sender node in one instance and a DMX receiver in another instance and have them communicate with each other.

I works with regular UDP nodes and also the VL-ArtNet nodes

ic, that is due to the way those nodes are dealing with the udp-sockets internally. would need some rework that i don’t see high priority at the moment. lets focus on the getting the new (vl based) artnet nodes usable. what would be a reason not to use those?

The reason right now would be if you don’t want to use an alpha version.

But I am already using alpha, so going for the VL version is fine.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.