Forum

Videotexture is blurry

i have mapped a videotexture (hd-video) on a quad. If i play it in fullscreen with vvvv it is more blurry than it is with a videoplayer (e.g. windows mediaplayer) in fullscreenmode. is this something i have to accept or is there a way to get a sharper image. thanks for any suggestion,

felix

use an inspektor window (ctrl+i) to set your desired size of the renderer in fullscreen mode…

thanks, but i think i have chosen the right fullscreen dimensions. now i have made another test (file attached): one screensot of the video played in native dimensions in the media player, one screenshot of the directx renderer (resized to the resolution of the video - both not in fullscreen) the media player screenshot is much sharper. i dont know how the resizing, overlay, … works “behind the scenes” but is there a possibility to influence it in vvvv? thanks again…

test_videotexture.jpg (92.5 kB)

halo felix.

from you screenshot i’d argue what you see is not blur, but interpolation. “behind the scenes” vvvv is copying the videotexture from one place to another. for this copy-operation directx offers two modes (if the graphiccard can do it): D3DTEXF_POINT or D3DTEXF_LINEAR. vvvv uses the “better” one available.

you cannot influence that within vvvv but maybe you can force your graphiccards options to “low quality textures / higher performance” (something like that) which could result in the more pixelated image you seem to be interested in.

@joreg, filter (ex9.sampler state) has no influence on this?

ja. could try this too, maybe. connecting a filter node to the quad the videotexture is on and set all filters to point for a test.

thanks to all of you - the filter(ex9.sampler state) helped to recieve a better result - its not the same quality like the videoplayer, but i can live with it

felix… its important to scale the the quad to the same pixelsize as the movie has, this way you should achieve the same quality…

And there is still the always annoying “shift the texture something like one pixels in x and y” to match up texels and pixels as they have somehow different origins in vvvv.

LINEAR blurs the image only if the texel centers are always exact in the middle between the pixel centers so that four texels are linearly interpolated to get one pixel. For some historical quirky reason this is the default in vvvv. In case you switch to POINT, you will get no blur, as always only one texel is used, but you can not be sure which of the four surrounding. A wireframe diagonal in your source texture or some typographically inclined client will usually reveal this.

The usual solution is to shift the texture about 1 pixel in x an y with a transform node. At a certian setting you will see an increase in sharpness also in LINEAR mode. If you have this, switch to POINT, as it is the fastest, and you dont need any interpolation anyway.

In case source and target have exact same size and LINEAR and POINT give different results, it is most probably that texels and pixels are not aligned.