VideoTexture bug in beta 22

Hello. I’m just found this ugly bug in VideoTexture node when it’s works with VideoIn from webcam, thats using default Windows7 drivers. It’s interesting, because in beta 21 all works fine, but in beta 22 video texture looks like as in attached file. Also, i’m tested PS3 Eye camera- works fine in both versions. I’m tried to connect VideoIn node to Cheater and then to VideoTexture - and i’m was surprised, because texture from camera starts working normally. But i can’t understand why.

Beta22 videotexture BUG.PNG (215.5 kB)

mmh…seems to be a videoformat issue. does VideoIn offer different formats, like RGB and YUV? try an RGB one, if there is.

It’s YUY2 and not changeable in both versions (21 and 22).

uk and have you tried it with the VideoTexture (EX9.Texture VMR9 YUVMixingMode) node?

Yes. It’s works but only with cheater node. Without it i have same error.

hm, i was hoping with VideoTexture (EX9.Texture VMR9 YUVMixingMode) it would work without cheater, as that should take the YUY2 format directly. cheater forces a conversion to RGB which seems to be accepted by your videotexture. cannot debug this at the moment since i am lacking a webcam that works on win7. however using cheater seems like a good workaround for now.

Ok, thank you.