VideoIn crashing

hi there,

i just recieved two new philips webcams (nc1030) which i intended to use for tracking in an installation that should be ready in a week.

unfortunately they did not work as expected in vvvv. after installing the latest philips drivers (, rebooting it works wonderfully in every windows app i tried - except for vvvv.

a few seconds after i insert the videoin node the app freezes (symptoms sound similar to the symptoms described by fluff here. in the latest post of this thread joreg mentions that he might have found the bug and the fix will be included in the next release (beta<20).

my questions: is there a workaround to get the camera going? if not - will the next release be during the next days? :)

if not, i have to look for a replacement very quickly…


i forgot to mention - i tried the cam on two different computers with the same result.

do you know of any alternative drivers that might work?


beta21 is here. can you try that again and report back?

bug with beta20 and beta21 too

hmm, too bad. i could probably fix that if i had such a cam to debug. anyone in berlin?

bug with 19.1 and 18 but it works in graphedit…
and ok in beta12 !!

servas joreg,

i could lend you a cam to debug the thing (i’d snailmail it if you want to). tell me if you want me to proceed (and tell me how).

ok motzi,

please send me a message to joreg (a) vvvv org

you’ve got mail!

Hi there
Having similar prob with philips spc1300nc webcam.
It causes the vvvv to crash when ever i open the videoIn node.
please kep me informed for this issue.
Thanks, your dowing a great job here.

… same problem here (beta21) with a Philips SPC2050NC that I bought because the specs looked promising.

vvvv freezes apprx. 5sec after adding the videoin node.

My feeling is, that it is a problem with the strange philips driver and the stupid CamSuite that has to be installed with the camera. The camera also is not working nice with amcap.
You can see an Image in amcap, but everytimetime you want to change basic settings within amcap this CamSuite is popping up and doing strange things.

I doubt these cameras will ever work properly in vvvv (my personal feeling)


ahh … uninstalling PhilipsCamSuite helps for amcap … but not for vvvv.

… not a real problem for me, i have now seen the crappy video quality (vertical stripes in the image) in amcap and decided not to use this camera for what I am planning to do.


ouright, seems i got that fixed now (for beta>21)

both on xp and vista motzis philips spc1030nc worked for me without any problems before i installed the philips driver!

with the driver i experienced the crash which i was able to fix. this could also fix the problem for other webcams that have a trigger-button.

biiiig thanks for that!

Hi joreg, Thanks for solving this issue.
how do i get it work? simply download latest beta 21 again and install it? or is there a patch i need to download?


helo tamir you need to wait for a version labeled beta22 (or higher) to appear in the Downloads. we are working on it…

Thanks A milion, waiting for the V22

Hi Joreg,

big ups for you guys for working hard on improving beloved vvvv!!

Is there any chance to get the Philips Cam (I got the SPC 1330NC) to work in vvvv at the moment?
I’ll have to finish a project by next Tuesday, so I’m afraid I won’t be able to wait for the release of beta22…
Or should I buy an alternative cam right now verrry quickly?

Der Dani

PS.: You mentioned that it worked fine before installing the Philips driver. How can I avoid WinXP installing the drivers? I uninstalled all Philips software incl. cam driver. But if I connect the cam to the pc, it automatically installs the drivers…

I think I have the same problem with the integrated camera of my lenovo sl500 notebook (latest camera drivers, win vista 64, vvvv beta 21).
no luck with re-installing vvvv and/or the driver.

just wanted to let you guys know.

wow, where did you get beta22?