Forum

Video Help

hello im from méxico and im having problems while trying to record with DX9 texture and the WRITER …

the thing is that im learning to apply textures on a video . i made an edition with some modules(effects, such as radial blur for example) i have a 6:00 mins track , now the problem i found is that the FPS is not working as i want . i mean when i put the FPS (lets say at 5, 6, 10, 20, etc…) some “scenes” were lost and at the end of the video never SHOW ME THE CORRECT TIMING (6:00 mins) … my laptop(windows vista) is also bacame “slow” while pushing the record button (which is hard while trying to do some REAL TIME)

how can i made to RECORD this video in the CORRECT TIMING ?
with no “slows” and no scenes lost…

im open to any kind of suggestion , i´ve been trying and i havent figure out yet …

thanks for your time i will really apreciate any help … cheers
for sound i use voxengo recorder(vst-.DLL placed on vst folder) which is really great , tht makes me thing that probly a .DLL video recorder would help(well, if they exists) …???

hi marioquiroga
are you using the node MainLoop ?

if not, can you post your patch ?

;-)

Recording your work in real time is a bit nasty, because your patch is running, and than you are trying to save every frame to your hard drive. Better is it to use an external tool, this is asked many times before.

Short answer
Longer Answer

hello, for quick and dirty records you can use fraps.

for high resolution videos you have to use the non real time writer module Writer (EX9.Texture NRT). but before rendering your video, you have to record the sound data with the FFT recorder.

for an overview look here.

this is the patch karistouf

sorry karistouf i forgot to add the download link

LINK:

http://www.sendspace.com/file/c2yj95

hi mario. best is to attach a .v4p file ( like here) by using the attach file button of the New Reply box.
a jpg is good BUT its not showing hidded troubles ( states of pins for examples, or hidden patches ).
so i recommand you to post your patch directly, this will be very very efficient ! especially if one day our dear uncle Kalle have a look at your troubles ;-)

i made a try like with this patch, never used writter.
usually i m usig Fraps, wich is not poor and dirty.
your question is a good question for me.
perhaps you dont need to write when there is a new image counted.
i mean the main loop is there to stabilize all the process on frame rate idea. but well it seems to work. maybe west could help ?

by looking at your attachement: WHY a 4.3 frame rate ?
you need or 25 or 30. But doing a conversion with a flotaing point number should not be good.

hope this will help you ;-) cheers

hi mario. best is to attach a .v4p file ( like here) by using the attach file button of the New Reply box.
a jpg is good BUT its not showing hidded troubles ( states of pins for examples, or hidden patches ).
so i recommand you to post your patch directly, this will be very very efficient ! especially if one day our dear uncle Kalle have a look at your troubles ;-)

i made a try like with this patch, never used writter.
usually i m usig Fraps, wich is not poor and dirty.
your question is a good question for me.
perhaps you dont need to write when there is a new image counted.
i mean the main loop is there to stabilize all the process on frame rate idea. but well it seems to work. maybe west could help ?

by looking at your attachement: WHY a 4.3 frame rate ?
you need or 25 or 30. But doing a conversion with a flotaing point number should not be good.

hope this will help you ;-) cheers

enregistrement en direct.v4p (12.3 kB)

karistouf

i tried to attach the file but seems that i have to put a quicktag also or something cause i saw nothing …

i uploaded to sendspace bro

http://www.sendspace.com/file/4r68sg

i tested the file you sent me but doesnt help me … still the same slow thing when i press record , also if i use 25 or 30 fPs the final result is 0:44 seconds of 6:00 mins … thats why i use 4.3 which is the more accurate to the original VIDEO … at the end (with 4.3 fps) i get 6:53 . the problem is that the movement is not so good i mean kind of robotic haha…

thanks for your time , preciate your help man !

hi, mario, the file is not complete. you need to put the fx files in the same directory where lies your patch, and then when clicking the fx or subpatch included,press shift Alt P ( relative path).

what is exactly your computer specs ( xp / vista / seven / RAM / Ghz of processor and number of processor) ?

wih version of rgbcontrast are u usi,h (1.4 or 2.0) ?

hi, mario, the file is not complete. you need to put the fx files in the same directory where lies your patch, and then when clicking the fx or subpatch included,press shift Alt P ( relative path).

what is exactly your computer specs ( xp / vista / seven / RAM / Ghz of processor and number of processor) ?

wih version of rgbcontrast are u usi,h (1.4 or 2.0) ?

snap.jpg (38.8 kB)

thanks again karistouf ,

computer specs
windows vista home premium
processor:intel®Core™2 Duo CPU T5250 @ 1.50GHz 1.50GHz
RAM:1.0 GB
32 BITS

and this is the link of the complete stuff man
http://www.sendspace.com/file/lr04vu

hi mario. you need to select (click) radial_blur.fx, flame.v4p, and make an Shift-Alt-P together.
otherwise your patch will not work for others. i have same cas on this new send.
:-( This can be tested easely by poutting the folder with your patch and effects in aother place on your computer and open it and see if everybody is really linked together as it should.

About your problem:

well, i have made just little essais with your animation only with blur effect and a video playing , this on a low machine (1.7ghz XP monocore, 2GB RAM).
yes my frame rate is getting down… very down.
1GB of Ram is very low on Vista.
what is your graphic card? Model and Ram / Dedicated memory or exchange memory ?

IF you have a correct result on screen , without recording,
I will suggest to you to try first to put the place to record the avi file on another Hard Disk, so on a complete different head that the head that is reading the avi file.
This will help you on your computer, because this one is slow if you are trying to play 2 or 3 shaders at the same time.

Fraps is a good software to record without too much consuming ressources. But you need to test it and see if it fits and do the job.

voilà ! sorry not to be of any help …

hi mario. you need to select (click) radial_blur.fx, flame.v4p, and make an Shift-Alt-P together.
otherwise your patch will not work for others. i have same cas on this new send.
:-( This can be tested easely by poutting the folder with your patch and effects in aother place on your computer and open it and see if everybody is really linked together as it should.

About your problem:

well, i have made just little essais with your animation only with blur effect and a video playing , this on a low machine (1.7ghz XP monocore, 2GB RAM).
yes my frame rate is getting down… very down.
1GB of Ram is very low on Vista.
what is your graphic card? Model and Ram / Dedicated memory or exchange memory ?

IF you have a correct result on screen , without recording,
I will suggest to you to try first to put the place to record the avi file on another Hard Disk, so on a complete different head that the head that is reading the avi file.
This will help you on your computer, because this one is slow if you are trying to play 2 or 3 shaders at the same time.

Fraps is a good software to record without too much consuming ressources. But you need to test it and see if it fits and do the job.

voilà ! sorry not to be of any help …

Bureau.zip (3.8 kB)

hello karistouf
i dont know here to find the graphic card stuff

Mobile Intel®965 Express Chipset Family???

let me tell you that fraps is working hell good , the only bad crap is that i have to buy it but works damn fine …

here is the link of the patch

http://fs09u.sendspace.com/processupload.html

i tested on my computer and it opens well , let me know cause i find it weird that everytime i press shift+alt+p the windowms media player appears …

thanks very much and you always help me a lot bro …

about fraps: you buy it but keep its setup exe, you can install it on other computers ( please consider to make people nuy it , its not a bad price)

writter with vvvv works if you run it from another patch, not in the same window, this without lagg