!Urgent! Focusrite Saffire 6 USB and novation Launchpad on W7


im having a problem. Can’t use together a Novation Launchpad and a Saffire 6 usb.

I’ve tried all usb ports combinations but nothing. If the launchpad is conected, it works, but if the saffire is added, it doesnt.

this is on W7 home

anyone with this hardware who can help me

this is urgent!!!

hey manuel,

did you try them on the same hub? (on the mainboard i mean)

did you also try an external hub with dedicated psu?

most of my issues with usb connections (i had plenty of usb issues :D) came from power/bandwidth limitations. (hint: it should be rather unlikely that a lack of bandwidth is the cause of your problems ;))

Seconded, try to use the power supplies that come with your hardware.

if only one device appears, or if you plug each one and see them but alone only, this is a power isue: use a powered usb hub

thanks guys

The weird thing is that both devices appear on windows devices administrator, but only the first conected works.

I’m going to try with a hub.

The support team gave me this article that may be related



just tried adding a cheap usb hub, connecting the launchpad to it, then connecting the saffire on another port of the computer and both worked fine

be aware that this something happening with usb powered devices. especially with led feedback ;-)