Unidentified error

i have hesitated in reporting this error as i cannot reproduce it straight away but its been happening for quite a long time/many betas <= 27.2

the situation:

  • preparing a video performance, im setting up render transforms, mostly homographies, that remain unchanged for the whole set
  • during the set i often add and delete modules containing graphics (layer output)

the error:

  • insert one of my graphic modules inside the main patch
  • connect it to an existing group node
    -the rendered layer is ignoring view/projection transforms
  • problem gets solved by dis- and reconnecting the module that has generated the problem

the hardware:

  • desktop with asus p6t7ws mobo and 5 geforce 9600s, winxp
  • desktop with eyefinity 6870, win7

im having a hard time reproducing this, because it happens:

  • randomly
  • rarely
  • using different graphics modules
  • using different render transforms
  • using different projector counts
  • using different resolutions
  • at odd times (during a performance)

if someone has experienced something similar or has a plan for reproducing this error, it would be welcome.


hmm do you have 3d layers inside of homo?

some modules i keep adding/removing contain ex9, some dont

just homo with 3d layers inside works bit different

it seems something outside of the patching, to do with connections that one time are being made properly and another time something doesnt click together in the pipeline

anything in the tty when this happens?

i will make a tty file writer and wait for it

Are the transforms attached to IO boxes that get values from another patch?

Back with a new report, patch attached (thow it probably wont reproduce what im describing).
It is a little different from the general report described before, but its the same, randomly occurring error, having to do with connecting dx9 layers over a group node to a multi-screen setup:

Patch contains:

  • two dx9 object, A and B (simple, common nodes)
  • one group(layer) node, input pins 1 and 2
  • two renderers (main out, fullscreen on secondary screen and preview out, windowed on primary screen)


  • connect object B to both inputs of group node, 1 and 2
  • connect object A to input 2 (object B stays connected to input 1), by replacing the link, instead of deleting the old one and adding a new one


  • windowed renderer only shows up object A
  • object B somehow gets lost in the pipeline
  • tty says nothing
  • resetting Group solves the situation (ill have to describe this more accurate when it happens again)


  • bootcamp with ati6750, win7-64
  • has happened on other computers (see above report)

group error report.v4p (25.3 kB)

there is something wrong with your IOBox (Node) labeled 1. make a new one or connect directly to input 1 on the group node, then it works.

perhaps you at some point connected a texture or something other than a Layer to the IOBox (Node) and thus changed it’s type to something other than Layer.

weird, the first time I ran your example patch, I got the behavior you described. but now it behave as expected.

so I saw you reported error once, but can not reproduce it with the freshly downloaded file

hmm i think i put the iobox there for describing the problem, not sure it was there when the error initially occured. anyway, how can you tell its smth wrong with it ?

I can tell there is something wrong by connecting b straight to the group node.

since it did show content a in 2 and not 1 it was probably something wrong with 1 so I tried bypassing the IOBox as the first thing and then it worked

b33.7 and the bug is still here, dx9 and dx11
now it is getting clearer that objects such as transforms or textures are not properly loaded per every gpu head when un/re/grouping them.
i have to manually dis- and reconnect group nodes for them to fall into place.
group node error is reported in tty.

(sometimes) if a texture shows up on say only 3 out of 5 heads and i connect a new texture source, an xor comes in effect, presenting the new texture only on the other 2 heads.
does this hint to a broken toggle in some resource management system that is under the hub ?

also, pls remove the resolved mark on this thread, the switch seems admin only

DX9 and DX11 are very different systems, so if the behavior is the same its more a hardware/driver related problem and there is very little a programmer can do.

so you need to find the simplest possible test case hardware and patch wise with reproducible steps in order to debug the problem.

Meshes and Textures missing from NVIDIA GTX 275, 280M and 970M for all driver versions since at least 4 years now. Happens exactly in the cases described Unidentified error by @ggml.