“Unable to load DLL LeapC.”

hi all,

I tried building the VL.leapOrition help patch with the latest stable and preview
2022.5.0696. Building success in each case, but when running the app, I get the error “unable to load DLL LeapC.”

When clicking continue, the stable build initializes the leap and works normally. However, the preview build seems to be stuck in a loop. I am unable to get it to run. In-Editor, the help patches work both - in stable and the preview.

err.zip (2.3 KB)

Interestingly, I have a skia and stride app using leap, which builds with the latest stable and runs without this error. I tried building this app with the latest preview (2022.5.0696). It builds, but throws the same “missing dll” error.

Sounds like the preview doesn’t copy that dll to the output folder. Have you checked if it is in there?

What version of VL.Devices.LeapOrion are you using? I believe only the latest one (1.2.1) has the correct package layout which should copy the native dll beside your exe.

Sorry, my bad. I was on 1.1.4 on both preview and stable. Now switched to 1.2.1, and all cases are working!