Forum

UDP Problems

I’m having some odd problems with udp and cant work out whats wrong, I’ve tried patching a example but cant get it to break, however in my patch I have 2 different anomolies.
UDP(network server) has its local port fed from another patch as it can be set differently according to how the patch is working, but on loading get no input, disconnecting the input and reattaching and it works, I fixed this with a onopen and a switch.
UDP(Client) I have problems with sending it an IP address, if I create the address (with some -(strings) and +(strings) with in the same patch, it works fine, if I send the IP from elsewhere as I was doing it doesnt send any values, and TTY gives
00:04:48 - : TMUDPClient.Send reports exception

when disconnecting the node and alt right clicking the input after this I just get a text string in the field and the error continues.
If I disconnect the IP nodes that live in the patch and altright I get the IP address.
Somethings not right but I cant work out what, it seems to be something to do with the string coming from a separate subpatch, but I cant recreate this…
Has anyone had anything similar, is it work pursuing the root cause of this issue, or just continue with this work around?

  • UDP (Server)
    “…but on loading get no input, disconnecting the input and reattaching and it works,…”
    which input are you speaking of? are you disconnecting a link in the patch or the udp-connection?

  • UDP (Client)
    hard to guess. here it would really help if you manage to give us a demopatch.

hm, i can’t remember such problems. anybody else with a hint?

I had a weird problem with UDP stopping sending packets a while ago whilst using fugStreamSend. A hotfix from M$ fixed it.

Windowsxp-Kb885894-X86-Enu.exe

Maybe throw it on and hope it works!