Forum

TUIODecoder-Index was outside the bounds of the array

im tried to using tuioDecoder with b27 today,but not working probably and it throwing some Exception error message:

Exception class: EClrException
Exception message: Index was outside the bounds of the array.
Exception address: 00000000

System.IndexOutOfRangeException: Index was outside the bounds of the array.
at OSC.NET.OSCPacket.unpackInt(Byte bytes, Int32& start)
at OSC.NET.OSCBundle.Unpack(Byte bytes, Int32& start, Int32 end)
at TUIODecoder.TUIODecoder.Evaluate(Int32 SpreadMax)

does anyone have the same problem?

hei liquid,

just tested that. basically works for me. can you be more specific about your setup/patch?

@joreg,i’m testing with this really simple patch. and using oscemote and tuioPad on my iphone. basically,once i connect it,the tuioDecoder pluging became red and flickering all the time. the TTY window message saying above error message. am i missing something? thxs!

hm, just tried with tuiopad from an iphone and it also just worked. i don’t really have an idea what could possibly go wrong there…

hey,joreg,sorry to bring this up again.and really hate to say this,the tuioDecoder really not working here,did some testing with elektromeier today. that seems the plugin only working really well with non-chinese os. i’m not too sure which part going wrong.

as soon as i connect it to the Transform node,then like i said before,the tuio node became as red and throwing out some Exception error message.

anyone can confirm this not working with non-western system?
anything related with utf-8 stuff? or any ideas?
anyway,here’s the video.btw,i changed the tuioDecoder as dynamic plugin for testing only.

TUIO-error.zip (5.0 MB)
Tuiodynamic.rar (35.5 kB)