I believe i found a bug ,
i opened a patch made with vvvv beta 28 and it was working well , i opened the same one in beta 29 and it is not behaving the way it is suppose to.

The patch is a basic multitouch where a blob is detected a quad is displayed.
It does it but the quad is jumping all over the place, like the values are flickering. I am not sure where the problem is in the UDP-server node or the TUIO decoder.

Tested on 3 computers with beta 29 and it is doing the same wierd jumps on all of them. Then tested again on beta 28 and all is working good.

Data is given from an iApp TuioPad , Tuio simulator and my rather ugly home made MT table running CCv on a separate computer.

TUIO/UDP bug (1.1 kB)

i think you need to select the right encoding in the UDP module, one of the iso or windows encodings i guess… does this solve it?

(and a little hint, if you have just one patch for demonstration, please don’t zip it… saves some clicks over here)

Nope tested on every possible encoding and it still flickers. Only on utf7 was a bit smoother but still not as should be.

P.S it didn’t allow me to upload a patch so i zipped it.

I think you need a S+H node like attached to avoid flickering. you need to hold the incoming string to hold the last received value in the frames where no UDP messages are received.

mt2.v4p (4.7 kB)

I also spotted this bug just about 2 minutes ago. You need to use raw UDP node, set bigger buffer for it and decode string with win-1252 encoding.

Also, in your TUIO tracking software set the variable “verbose TUIO” to enabled (it’s allows tracking software to send UDP packets every frame).

also please try your unmodified patch that works with b28 with latest a29.1. we’ve supposedly fixed such an issue. please report!

Sorry for the big delay I was on the road a few days.

To clarify the patch i uploaded works on b26, b27,b28 without encoding adjustment also the UDP node is not a sub-patch as it is in b29.
Also same results for me on several different computers with the latest alpha. ( i am getting some error when starting the demo patch with the latest alpha , will report it in the alpha section )

I am not saying these options are bad , i am just a noob and probably didn’t even know i had to adjust them sins they were working out of the box in the older versions of vvvv.

@ Sunep - you are probably corect about the S+H node, but i did it so i dont have quads displayed when there are no blobs (i could still be wrong though).

@ alg - tested it the way you said and yes it is way smoother , but when compared the movement of the quads with older versions it is still jerky , it looks like the quad is trying to snap to the edges of the renderer.

Thats it from me . Again it could not be a bug but simply a lamer behind the keyboard …

@synth: alg is right. setting the encoding on the udp node to win-1252 should actually work as that is what TUIODecoder uses internally. if it still doesn’t i have to say i am not realy sure whats going on there.

the best option will be to change the TUIODecoder’s input to type Raw. and luckily it is opensource so anyone can go ahead…