Trying to rebuild the Skia MultiTouch help patch

… and struggling right from the beginning. There might be some knowledge about building datatypes missing over here, so I’d appreciate any pointers. I am curious why the data within the “Asset” class is not being delivered from one pad to another like it is doing in the original help patch.

What also makes me curious is that in my patch the arrows above the pads after the Decompose are missing. What are these actually for, what do they indicate?

Sorry if these might be noob questions but first cut is the deepest.

MultiTouchProblem.vl (28.5 KB)

The transformation of Asset is calculated on Update, but Update is never called/executed so Split returns a default transformation.

Yeah, thanks. Works now! This would only leave the question about the arrows above the pads, because although it works now they still don’t appear.

I guess the arrows only appear if the value of a pad is set in multiple operations or if the value already is already being set in the same operation.

right. the arrow over a pad is indicating that this pad is also written to:

  • at another location
  • from another operation (except create)

in the help patch you refer to, the Translation, Scaling and Rotation pads are written to on update, in your example not. that’s why in the help patch the pads below the Decompose show the arrows.

Thank you for your replies! I have another question regarding this patch, talking about the MTStack process node. How exactly is that Break output of the inner ForEach triggered? I thought a Break Pin inside would be needed for that…

absolutely! thing is: this is a rather old patch and there was a bug in an earlier version that would hide index, break and keep pins of loop regions, even though they were still working. i fixed the patch for >2021.3.1 and it will look like this:


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.