Forum

Trouble getting started devvvveloping plugin

Hi,

I’m trying to start developing a little plugin. I got the vvvv-sdk from github, was able to successfully build my first test node and use it in vvvv.

However, I struggle a little bit with understanding how data is being passed between nodes. My plugin is supposed to parse a byte stream received from UDP. Now I tried to do the following:

[Input("input data")]
IDiffSpread<byte> FInput;

however, in vvvv I am not able to connect the output pin of UDP (Network Server) to my input pin. For testing I was thinking of using Byte (Text) as a node just generating input as taken from an ASCII string IOBox, but I also can’t connect its output. I also tried int instead of byte, no success.

Moreover, I am not sure if this is the best way to go in the first place. What I actually expect is not getting my input as a spread of varying size depending on the data I read from UDP, which, depending on the implementation, may or may not be efficient, but as something like a ByteStream or such (i.e. IDiffSpread<ByteStream> or IDiffSpread<byte[]> or similar).

A few questions arise:

  • What is the output type of *UDP (Network Server)
  • How can I figure out such things without asking in the forum (i.e. is there a documentation for that?)
  • Are there examples out there that I can hold on to for making my first steps?

Thanks for your help.

Have a look at the Raw nodes in the vvvv sdk:

1 Like

there is also a dynamic plugin template for a node with a raw in and output, that should be a good start:

grafik

it shouldn’T be necessary to work from the sdk for that.

2 Likes

Thanks, that helped.

Btw. there seems to be a bug in the current develop implementation of the unpackChar method of OSCPacket, as start is not advanced. In OSC char is a non-standard type sent as a 32 bit integer, so you may just call unpackInt at this point. I’m new to vvvv, what’s the modus operandi in this case? Create an issue on GitHub?

thanks for pointing that out! you can either send us a pull request or wait for when we find the time to fix it. we’re are tracking issues in the forum and respond here when things are fixed.

@ithrak this is now fixed in code and will be in binary with future beta-previews.

1 Like