Trautner crashed

the lastest alpha,seems the Trautner doesn’t work, reported as APPCRASH,Fault Module is libopencv_imgproc231.dll. also,the ARTK+Tracker node with videotexture not working atm,no given images. if i delete the ARTK+Tracker node the error message sayin:

Exception class: EAccessViolation
Exception message: Access violation at address 152DFBCC. Write of address 62B29B11.
Exception address: 152DFBCC

its random,not all the time.

hm. both trautner and artk+tracker are working for me in the latest alpha.

the crash on your side seems to be related to the new opencv2.31 libraries used. do you have the same problems with the other trackers (contour, camshift, color, fiducial)?

can you report some details about your cpu?

no,the other trackers working as usual. only the Trautner has a problem.
my cpu is Intel Core™2 Duo CPU P8700 @2.53Hz
i’m running win7 64 bit,btw.just for clarify,when i open the traunter help patch,the videoIn node is red (which seems to me is a normal,because the videoIn node somehow can make the YUY2 as defaut format,so i always have to change it manually,same thing with beta27.1&27),but that’s fine like i said still can working with other trackers.

as soon as i changed the format from “none” to “yuy2”,till the ActiveMovie window pops up,it causing v4 to crashes.

Faulting application name:vvvv.exe
stamp: 4f95b2ad
Faulting module name: libopencv_imgproc231.dll
stamp: 4ec661fb
Exception code: c0000005
Fault offset: 0008bb8e

does your cam/driver have an rgb24 option? and does it work with that?

sorry,no rgb24 or rgb32 option,only the YUY2 available.

think only rgb works with freeframes… You can do:
renderer in between then dx9texture with rgb format as video and should work

thxs for the help,will try that too. but another strange thing is that i replaced all the opencv from openCV2.3.1.
after that the Trautner start working also the videoOut window. then,i testing with other trackers,and CamShiftTracker stop working this time(the rest are fine),same error again,so i thought maybe i have to recompiled it against the opencv2.3.1,and i recompiled with cb. this time,the CamShiftTracker working, however the Trautner did crashed again,same error. no idea what’s going on here,any clues? cheers
btw,if nobody don’t have this problem,that’s fine,maybe just my crappy webcam or something mess.

ok, so it will work in b27.2 but with beta>27.2 the new opencv libs will come and it will not work again. so please tell me again what you did there:

does that mean you replaced the files in \lib\thirdparty\opencv with files you downloaded elsewhere? if so please point me to those.

i downloaded from opencv sourceforge which is here ,the OpenCV-2.3.1-win-superpack.exe one. and replaced the files from opencv2.3.1 folder build\x86\mingw\bin to vvvv\lib\thirdparty\opencv

but all the trackers working with this bugfix-release you posted yesterday alpha27.2-a-conservative-bugfix-only-release

thanks for the help.

just noticed,the alpha28 still got same issue with Trautner node.

oui, think i got it. please try this alpha28. seems to have been an opencv231 problem. upgraded to 241 and the problem is gone here.

please confirm.

super,working great. thxs @joreg