Tearing during video playback with 50Hz


i’m new to V4 and totaly amazed :)

I’m working for a videocompany and try to replace our Dataton Watchout System with a VVVV System. But before using it during a Show, i first want to play with it and check if it works well for us…

My first big problem is about tearing http://en.wikipedia.org/wiki/Screen_tearing

I used a EX9 Renderer, a FullscreenQuad, a VideoTexture and a FileStream2 to play back a 50fps Videofile. The Renderer Fullscreen RefreshRate is set to 50.

While i play that Video a tearing appears for about 1 Minute in the upper third of the Screen. The “horizontal break” slides up slowly to the top. Then everything is fine for about 2 minutes and after that, the same…

I tried to set the Fullscreen Refresh Rate to 60, now the tearing is gone but i got microstutter cause of the Videoframerate is not matching the Screenrefreshrate…

Changing the Presentation Interval doesn’t help me :(

Is there a way to play that Video smooth without tearing ?

Any Ideas on solving this Problem ?


have you set the monitor which plays the file in windows settings to 50Hz as well?

ah, and welcome btw… nice to hear someone sees the professional opportunities. as i am working on the video synchronization i would be glad about feedback about technical an/or usability issues.

hm. there shouldn’t really be any tearing in your scenario. can you try this on a different pc and/or graphiccard?

Thanks for your replys…

@tonfilm: Of course, i used a Lightware EDID Manager, to make sure its the right Resolution - 1920x1080@50p.
Thanks for the welcome :) The synchronized playback with a boygroup will be my next project… I will keep you posted…

@joreg: I got about 20 pc with the same hardware, i didnt tried all of them, but a few and they got that tearing :(

Tried that without a Video… The patch attached does the same for me (just at 50hz)

tearing test (4.2 kB)

i’ve only seen this happening with ati cards. but also very rarely. what graphiccard are you using? do you have latest drivers installed?

i use a nVidia GTX 440 with the driver released this night…

EDIT: got News!! Connecting the Display via VGA the tearing dissapears!! Seems to be a digital Problem…
Is there a way to force activate VSync throug VVVV??

vsync is enabled by default in vvvv. that is via the renderers configuration Presentation Interval which is set to “default” meaning VSYNC=true (in direct3d terms). try changing that enum to “wait for frame” which should acutally be the same, but could be worth testing. setting it to “immediately” means VSYNC=false.

Thank you joreg,

I think this is a bigger problem than i expected…

Changing the Presentation Interval has no effect :(

But i figured out something else:
I rendered my tearing Test patch to a videofile and got that same Problem during the Videoplayback in the Windows Media Player, so it seems to me that this is a systemwide Problem…

So i tried out to fix this Problem with some solutions i found via google:

  • activating Aero… no change
  • force activate VSync in my NVidia Drivers… no change
  • activate tripple buffer in my Nvidia Drivers… no change

so at the moment im really desperate, cause i dont know how to solve this problem…

any suggestions ?

i ve got some tearing problems once in a while. most of the time the (hidden) menus of the displays have some options (like “presentation mode” or “auto optimize” or sth like that) if you turn this off. the tearing disappears. as you are working for a videocompany i think you are aware of this settings. but this really sounds like the same problems i had.

thank you hrovac,

as i work with non consumer displays, they have no options like that… But im thankful for every hint…

it doesnt matter wich display i take and im sure the problem is a graphiccard problem…

OK i think i found the solution:

i attached a dvi splitter 1->8 and connected every displaytype we got to that splitter, that they all receive the same signal!

Not every Display is showing the tearing… Only the “small” 24_computerdisplays (which got a native 60Hz refresh rate and just interpolate the signal to 50Hz) got that behavior… The Proffesionals (like a 40_ NEC Display) with a native refresh rate of 50Hz, are clean!

So this seems to me hrovac was right and this is a display problem, not a driver, windows or vvvv mistake ;)

Thanks everybody for helping me to find the solution!


what happens if you set your renderer to 60Hz? Is any stutter noticable?

yes for me the drop frames are reconizeable…