TCP connection, Port taken

Hi there. I am trying to use the TCP nodes to communicate, but I run into the issue that the ports are unreliable. I just watched the Nodes Workshop on Networks, and there it is mentioned, that there is an issue with the underlying library, so when a port is closed, it is unfortunately not closed, so when you re-enable it, it remains taken from the previous connection. The workaround there is to just increment the port number, which unfortunately is a solution that won’t work for me. The moderator mentions plans to fix it, but looking at the nugget, it seems, there has been no update for the past 9 months.
Has this been fixed since, or/and is there a workaround to this issue?

i’m the guy who did the workshop on network protocols at node20. the TCP nodes did indeed have a bug then but that one was fixed by @joreg right after the festival (which was 9 months ago) and i remember they worked fine then.

just gave a quick try with the helppatch and it seemed to work as it should.
are you on version 0.1.5-alpha?

Hi Motzi.

Thank you so much. It seems it is working now, maybe I had an older version installed.
I have another question related to this.
I have the clients running a remote device and the servers run on the computer via vvvv.gamma. When I try to connect it does work when I use as IP addresses. Once it connects it shows my network connection is on, which is what I had configured on the remote device.
If I try to make the IP specific and replace the with the it no longer connects.
Is this supposed to happen, or what would be the reason for this?

Check out this thread:

please see the explanation for external connections here: GitHub - jchristn/SuperSimpleTcp: Simple wrapper for TCP client and server in C# with SSL support

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.