Forum

Stride's Skia Texture, doesn't handle the right color space

SkiaTextureBug.vl (10.5 KB)

yes, seems to have the wrong default pixel format, for now just switch to a Srgb format, like so:

image

the default will be changed for the upcoming preview.

you can also render directly into the output, without the texture step, this is also more efficient:

image

1 Like

Yes i’ve tried with Srgb aswell and it looks oversaturated, i’ll try with Skia Renderer

Maybe because you also have the default tonemap applied in your final scenerenderer … it’s an eternal source of confusion for us vvvv beta people ;)

You would need to render both in its own scenetexture. Everything with actual stride content having tonemapping enabled, the texture with skia content disabled. Then merge the two in a third and final pass …

Maybe these kind of use cases (which turn up very often) can be solved a bit more elegant by excluding pixels from tonemap/postprocessing with some kind of mask?

1 Like

You can also set the render stage of the RenderEntity to AfterScene, this will draw after the PostFX and is therefore not influenced by the tonemap.

2 Likes