Stride quad transparency seems broken


Works that way

Does it work if you connect an AlphaBlend node?

Transparent stage won’t render anything transparent just because it’s been moved to that stage … it just means it’s being handled differently by the engine for a couple things like e.g. depth sorting. It will do the same for every object in that stage, also opaque ones.
Like Tebjan proposed you have to set the blending up with any of the transparency nodes.

To make it clear, the problem is this:

Seems like the pin is not out.

Is it possible to blend more than couple of planes? Looks like there is a limitation

@yar with AlphaBlend i suspect you get what so called “ordered transparency”. So to blend you have provide your layers in order from back to front… I see you found pin Alpha to coverage, that the second option, but with it you don’t really have blend, you have basically “Alpha Key” (discard unused pixels) so it will be transparent solid and order independent… Proper image blending works with pixelshaders like TextureFX…

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.