Forum

Strange Fullscreen Performance Problem


#1

Hello everybody. I’m having a weird problem. I have an almost blank patch, just Renderer (DX11) and a Timing Node to Debug. Whenever I move the Renderer to my Projectors Output and Go Fullscreen there I got a massive performance drain, as in going from 120 frames to 40. That projector has a sizo 1024x768, but the Renderer shows a much bigger backbuffer size: 2560x1920, which irritates me. Anybody got an Idea?

EDIT: I tried setting the Renderer borderless as a workaround. Doesn’t help. Also tried with different cables / signal converters.


#2

If you have a ‘retina’ screen and are using 200% for example on your text magnification, I think that can make you renderers render at a higher rate than they should. So try turning that off, if its on.


#3

you can set the backbuffer size to a fixed value in the inspektor.


#4

is this running on a laptop or some pc with decent graphicscard ?


#5

Thanks for the advices. Right now I have not found a solution yet. When fullscreening the renderer the GPU usage bumps from 4% to 40% and the CPU from 2 to 15%. When I look into the advanced graphics settings, I see that the laptop’s screen is controlled by the intels gpu and the other screen by the nvidia card.

EDIT: When resizing the Renderer mnually to 4k (just tried it on different displa) and making it borderless, the framerate stays constant at 120 fps
EDIT2: Not really. I realized, I didn’t resize propperly. When draggin the renderer really over the whole screen, it just crashes

@u7angel it’s one of those fancy small gaming laptops. Aerox 15x, with dedicated nvida 1070 maxq.

@tonfilm that’s good to know, but the problem persists, just on a smaler scale. That laptop schould handle an empty renderer in a big resolution at 120 fps anyway.

@catweasel not that I knew about any special display features with this laptop. it’s got some color-related features (X-rite pantone) I haven’t cared about yet.


#6

aha, my question was aiming at that, so nvidia optimus again. i have similar problems sometimes with my dell xps. no solution though.


#7

@u7angel no hope? That thing costed a fortune


#8

ok, so activate the GPU activity symbol in the nvidia driver setting and check whether vvvv runs on the dedicated card…


#9

@tonfilm it does


#10

@u7angel I think I found a solution… there is a physx nvidia surround-option. you have to set it to the nvidia chip. For now it seems to work for me.


#11

@drehwurm could you make a screenshot of that option? I cant find it in the nvidia settings…

I found kind of a workaround for now that works for me:

1.moving the renderer to the dedicated window
2. moving the renderer to the upper area of the window so it maximises the screen
3. pressing the fullscreen toggle of the renderer

framerate stays high this way and the window is real fullscreen so no windows notifications will be visible


#12

@knoeterich

Here you are. Hope this helps.