Store.dll causing crash with 64bit build!?


I have started using the new 29.2 build - up from 28.1 - and am quite excited about finally using the benefits of 64 bit (mainly ram limitations).

I have quite a large patch with many subpatches, some of which are used some 128 times (1 for each midi note). It works ok in 32bit (around 1.6gb ram used). Once i tried to load it in the 64 bit build though it would get to 1.4gb and just crash.

I tried again with the alpha build and had forgotten to add the addonpack and it worked straight away, using about 1.9 gb of ram in idle state. I realised that I am using the store (spreads) node from addonpack quite heavily and it was an immediate candidate for testing.

Added the addonpack but renamed store.dll and again it loaded fine, showing that it is most likely the troublemaker.

Are you aware of this problem? is there a solution?

Let me know if you need more info.

Thanks, Armin.

can you make a more specific test using only a store node that demonstrates this problem on the 64bit build but works on the 32bit build?

Hi joreg,

well thats the problem. here is what i tried:

29.2 32 bit - loads main patch with subpatches fine

29.2 64 bit - loads main patch with subpatches a bit then crashes (win report says it was caused by clr.dll!?)

29.2 64 bit - loads only the subpatch fine

29.2 64 bit - loads patch with 128 instances of the subpatch fine

29.2 64 bit with store.dll renamed - loads main patch with subpatches fine, but of course store node is red

I can give you the error information from the 29.3 alpha if that helps.

Thanks, Armin.

please post a (simplified) version of your subpatch.
as you say that it crashes after loading main and subpatch: does it load and run for a while or does it crash while loading?
store is running fine here with x64 so i need to check your usecase to reproduce the problem.


Hi together,

similar issues here. I also work on a large patch with many subs. First I developed with the 32bit version. Because heavy texture usage, I switched to 64bit. Worked fine at the beginning but now trying to change the patches results in crashes. Like Armin from setzdesign described, the subpatches can be opened flawless. I get the same message with an error in the “clr.dll” (64bit version of .net framework).
I guess there are problems building the whole node path in the editor in the 64 bit version. I couldn’t determine a special node to cause these problems. Just adding new nodes or subpaches crash the 64 bit. Sometimes just labeling an io box for input causes a cras (guess becaus of rebuilding the patch structure ?!)
My temporary workaround: I use the 32bit version of vvvv (vvvv_45beta29.2_x86) for editing the patches (Used the “Large Adress Aware” tool to access more memory for the 32bit version, just google it, if you need it) and use the 64bit version (vvvv_45beta29.2_x64) for runtime on the client machine. Works for me at the moment spending 2 days of try and error…