Standard Getter and Setter operations as option

it would be great to just take the name of an output, when creating an opration.
I know it’s hard to find a general solution to that, since you can basically create operations anywhere.
But I’m doing this so often, I really would appreciate a shortcut.
For example:

I’d want an opration called Slides as the Getter of this property…


yes I agree, something like an option for “default” naming deriving by the name of the variable (Pad) and the flow of the link (SetSlides/Slides).

1 Like

Or maybe borrow the public/private concept with some adaptation:
Private could then mean you can only access the pad from the node (or maybe document if not namespace?) Where public would give you an automatic getter and setter that you can use outside.

The idea behind is to make it easier, less clicks and less visual clutter, while still retain control.


In most bigger projects I’ve been involved in, the convention was to also use the prefix Get for getters. If patches get big and complex with many operations, this helps a lot visually in the node browser.

It’s also nice to have this symmetry. The current convention to only use the prefix for setters is a mix of C# properties and Java get/set.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.