Skia Renderer won't show

fixed-for-upcoming

#1

Hey there

my Skia renderers won’t show, I tried in a VL patch without vvvv (in a Root patch that was evaluated) or in a node that I also have in vvvv. Weird thing: they clearly render, as when I click on vvvv in the taskbar, I see them:

When I click on that window preview, it takes me to the VL window.
Happens with examples and my own patches.
TTY complains about nothing. Anything you want me to try or test?

Not sure what to do or how to give a more detailed bugreport.


#2

are you messing with the bounds of the window?


#3

Did not mess with bounds of the window.

Found two things though:

  1. The Bounds pin is set to a zero width and height rectangle
  2. I can’t change that, seems to be a Rectangle type different from the one I have:

#4

This is latest beta 64bit, installed Skia via nuget as suggested:
nuget install VL.Skia -prerelease -Source nuget.org


#5

Have you tried latest alpha? Could be the prerelease bit…


#6

@catweasel interesting thought! Still the same in the Alpha though. Except:
image

Using the Alpha, there is a non-0 rectangle in the pin. Everything else is the same, can’t connect with the VL rectangle type, can’t see the renderer, can see it in the taskbar.


#7

Hey Dominik,

please check the latest (38.1) alphas.
The issue should be resolved now.

Best,
Anton