Sever (vvvv) not working in beta 34.1

I think I found this previously but didnt persue it, open the server(vvvv) help patch and it looks like server doesnt work in beta 34.1 (64bit)
Shame as I was going to try 34 to fix some other issues I had!

hei cat, please be more precise than “looks like server doesnt work” because i then open the helppatch in x64 and to me it “looks like it works” and then?

I get output from the osc mode when altering values but can’t write values to either the value or string up boxes that are exposed, nothing happens.

Ok tried again and it’s does, that’s interesting as it doesn’t with my kontrol everything patch, and didn’t earlier when testing, I’ll see if I can recreate it

well, cannot reproduce. in the helppatch when i scroll the iobox (in the right part) that sends the osc-message then the exposed (green) iobox in the bottomleft changes as expected.

does it work for you with x86? maybe a firewall setting?

In 33 we need to quote a pipe around colours and strings, in 37 we dont.
Is that in the change log?
Is that going to cause issues with any strange characters in text?

Ok it is mentioned, I’d done work arounds through out my patch, got to un-workaround I guess! Makes it awkward for backwards compatibility though, it would have been nice for it to be ok with pipes, rather than just break!

Server (VVVV) help.v4p (42.8 kB)

hey cat!

the change was necessary to get around a counter-intuitive behaviour pointed out by readme:

with the fix this got resolved too:

i hope that using the upcoming beta together with the patch adjustments due to the breaking change is an option for you… :/

String repaint still doesn’t work for me, hence in the patch above there is an iobox off the iobox!
When I started using kontrolleur joreg instructed that strings and colours should pipe quoted to work correctly, so by fixing this it breaks all the versions prior to this version. Ideally piped or unpiped strings and colours should work, otherwise it’s breaks backwards compatibility. I’m sorry gut the delay reporting this but when I tested and it didn’t work the first time I was in the middle of a project and didn’t have time to work out why, all I knew was my massive patch no longer worked! Also the changes in separate caused issues, so I guess really it’s not going to be backwards compatible anyway! I’ll just have to have version specific patches.

Let me check the repaint bug as to be honest I might have added the iobox in the 33 version!

hei cat, we could have indeed handled that more gracefully. please check (without any modifications to your patch) with latest alpha and report.

it now does like:

  • if string already starts and ends with pipes, nothing happens:
  • else it escapes each pipe with another pipe and quotes the string with pipes internally

that should keep your patches working.

@catweasel can you please report if that now works for you?

Somethings still broken in my big patch, I’ll have to spend some time to find out whats wrong!

you’re saying your patch works fine in b33.7 but not in latest alpha? any hints in tty? different to what you get with b33.7?

Thats correct, what seems to be happening is that spreads in a value io box aren’t being sent to the pins, in 33.7 I only needed to using s and a spread 0.1,0.2,0.3 for example and that would update the pin, now if I use sss it will update one of the fields but not all, are values now floats or is everything still strings?
I’ll try and dig deeper later, but it doesn’t work out of the box…

hm indeed, lets see…


so what you apparently used to do is: send a string like 0.1,0.2,0.3 typed as a single string (s) and what happened, is: vvvv split it at the commas and set the resulting list as a spread to the pin.

it comes back to the pipe-quoting:

  • b33.7 was like: any string that comes in
    ** if it is quoted with pipes then just remove the pipes and pass it on as is
    ** else split string at commas into individual slices
  • current alpha says: any string that comes in:
    ** if it is quoted with pipes then same as above
    ** else quote it with pipes to protect commas for people who didn’t know about the pipes

so now your string 0.1,0.2,0.3 gets auto-quoted to |0.1,0.2,0.3| and vvvv does no longer interpret it as individual slices.

so what to do

i’d argue the new auto-quoting is still good and instead of sending 0.1,0.2,0.3 you should simply send the 3 individual slices as such and simply give it three typetags (fff). that is the way you should think about it, not worrying about how to merge slices to a string so it gets interpreted as slices. see?

and as to your question of typetags: s vs f: both work in the case of sending single floats, but when you mean float you should use f not s.

i hope this helps to understand how you’ll have to rework your patch. it should be rather straightforward. please report if that helps to get your patches working on latest alpha.

Yeah all makes sense, I’m pretty sure I used s as f didn’t work previously, but I might be mistaken, I’ll rework it all and let you know!