While playing around with my vj tool built with vvvv , i discovered a new, and very strange bug. I don’t know if this one will happens everytime (hopefully not)…When applying renderstates to objects in my main visual patch, those are also applied to all the objects in the GUI…This one doesn’t happen when loading patches but only when modifying them…Any ideas where this could came from?

Happening only is this case : Changing renderstate modes before physicaly connecting the node. When connecting, applies chosen renderstate to the whole content… :(

reminds me somehow to this strange one

tried to reproduce it in a setup involving some patches, renderers and dx9textures. i used fill and blend nodes, switched the mode and then connected them to a certain object (Sphere (DX9)). couldn’t reproduce the error with that.

please try to sort out the error and send that patch.
other question: is there an error running in the tty renderer?

I finally found the problem after crashing my head for hours…Seems to come from the sobel edge detection shader(i’m using it in my post-processing shader) and the info(texture) node…If i don’t connect the info node to the shader everything is fine…but i don’t know why…explain it to me please…There is the demonstration patch… (6.2 kB)

thanks a lot.

Some news…
Seems that this bug is not limited to renderstates…I have new ones but hard to reproduce on the attached patch…Now sometimes when i apply textures to the main visual patch they’re applied to all the quads involved in the gui…another strange thing happens with lines…I use kinda vumetre for audio frequencies…if i use the sobel edge technique for the visual patch, then the vumetre, made of line, is displayed twice, once on the gui and once on the visual patch itself…this doesn’t happen if i use quads instead of lines for the vumetre… :(

fixed that one in the

i think with that also the texture bug you mention above should be fixed.

however the last one sounds like a different one.
for the latter please make a new topic.

for the one with the textures please attach the file here.

I can’t reproduce the texture and the line bug for now (happened several times but not anymore)…When this would come again i’ll try to isolate it inside a patch…
You said ‘fixed’. How?



how? i tracked it down until i had an idea what could have went wrong. then changed the a line in the source code. next version (>14) comes wih that changed line.

Ok, cool !
Thought it was something wrong related to the patch or the shader itself…good news!

Hi there,
Just tried out the new beta 15 and i see no change…the bug remains the same :(

Forget the last post seems to work fine…maybe i’ve open the patch under beta14
Gregsn, you’re the man!!!