Forum

Renders without alpha channel

I was having trouble with this earlier and posted in the shoutbox a little. I haven’t been able to render images in bitmap format without an alpha channel. I have tried rendering with and without the non-real time renderer and have tried some of the settings on the renderer as well as the blend mode and color channel nodes. The images always render with an alpha channel that just fills the screen. I want to eliminate it because it makes the files that much bigger. Anyway, any help is appreciated.

i can write bmps with 24bit (ie. without alpha channel) when i specify on the DX9Texture node (viewed with inspektor) a textureformat of 16bit, like R5G6B5. which is strange of course, because you would expect the textureformat R8G8B8 to result in 24bit bmps.

while this may already help you i have no idea why it is like it is and if the resulting bmp is actually 24bit or really only 16bit. can you check that?

The Windows Bitmap is not using any compresion, and thus creates very BIG files. Why you want to do that? And I didn’t know there was an Alpha channel in those files.

There is a ‘hidden pin’ in the DX9Texture node you connected to the renderer, you can see it with the inspector to select a format.
Just choose one without an A in it. But the standard, that is ‘No Specific’ doesn’t have an alpha channel.

So are you sure you mean alpha/transparant that you have the trouble from?

I didn’t think bitmaps even supported alpha channels either. I just rendered one through the NRT (with the default ‘no specific’) and it came out 32bit. I tried to delete the alpha channel in Photoshop to see if it would change the file size but when I opened it again it still had the alpha channel (although this time it was black).

Another question: Do you have to save the NRT settings before you render through it for them to be applied?

I know bitmaps are uncompressed. I want to render uncompressed video frames so there isn’t as much degradation when I put video compression on them.

When I put it on DIB (device independant bitmap) it seems to perform closer to expected. When I render with R5G6B5, the images are really small and apparently 15bit(?). Another strange thing is happening though. There is inconsistency in the background color between formats and versions of VVVV it seems. The renderer is set to a black background but sometimes I get white.

Do you have to save the NRT settings before you render through it for them to be applied?

no, it will render with the current settings even if not saved.

I want to render uncompressed video frames so there isn’t as much degradation when I put video compression on them.

since png compression is lossless there should be no quality difference if you render to PNG, but a quite big difference in size.

http://en.wikipedia.org/wiki/PNG

Okay, thanks. Perhaps it will be more consistent with PNGs.

Its still rendering with a white background or sometimes it renders one frame continuously or pure black or white frames. I think it might have something to do with clear being set to zero on the renderer.

I think its working how I want now. I turned off only render on save on the texture writer.

For your problem with the renderer color it may come from the rendere dx9 setting, if the antialiasing is set to an other value than zero the dephbuffer doesn´t work …
If you want to render picture with antialiasing you have to render with double size to have a good quality at the end.