Forum

Renderer - resolutions

My content patch pipes out through a shader and into a renderer. The output from this is pushed through a dx9texture onto a sphere. I’ve then got projectors shooting individual sections of this sphere and rendering different bits of the bent image.
The resulting render from projectors is currently at an unacceptably low resolution. What options are there within this setup for increasing my end resolution? I have played with the width and height of the dx9texture which helps to a point, but stops having any effect after a while leading me to believe that the problem is further upstream with the renderer or shader?
Is there a maximum renderer resolution to which I will be unavoidably constrained even if the render value is passed straight through to another patch?

there are pins to set the resolution of the renderer. those pins need to be feeded (width and eight) especially taking the result of a renderer to make a dx9texture. by default they are set to 0.

by default they are set to 0.

…means that the dx9texture’s size is defined by the renderer’s window size.

ahhhh… once again learning something with u , kalle.
by the way, hidden renderer for dx9texture is taking wich value when at 0 ? last opened window one ?
;-)

karistouf: i think it reverts to 256x256

benkyma: maximum renderer resolution is constrained by the graphics hardware. in most cases, it’s either 2048 or 4096 pixels square. might be the current generation is already at 8192, even.

thanks diki.
resolution must be a multiple of 8, and on your use of vvvv in texture, or video formats, you will see a real difference with truely 8x multipliers sized texture and others.

let me jump in for a minute;
what are the settings for making a dx9texture output identical to renderer (ex9) on pixel level?
working with a led screen on led-level (dividing, scaling down to lines of height of 1 led), i have noticed the second pass (texuring a grid of the same size) makes the fine lines disappear asif pass2 would bare a lower resolution.

hi ggml, just to set your output renderer’s resolution feeded with
same pixel resolution than dx9.
about your little troubles, markus was pointing this therad, maybe it could help ? http://vvvv.org/tiki-view_forum_thread.php?comments_parentId=25541&forumId=4&highlight=pixel

You should set the renderers backbuffer width and height to match the resolution of the video IF they are only used to generate a texture to pass on to another renderer, in which case the final renderer should be set to the output window size.

Another thing you can use to get smooth texture passing is to apply the texture to “bicubic(EX9.Effect)” in which give it a “grid(EX9.Geometry)” as a mesh and set the width and height (one pin so use a “iOBox(valueAdvanced)” with two colums). This dose bicubic and bilinear interpolation of the video which will scale much cleaner than a regular texture applied to a quad.