Forum

Renderer -> Projector

How can I easily “send” the content displayed in a renderer directly to a projector?

When I set the projector as the second screen and move the renderer window onto that screen, I get black background instead of my content. I was told by my professor that it’s a DirectX limitation, that it can only be displayed on the “master” screen.

Duplicating the screen and having the renderer in a fullscreen mode isn’t the best solution, as I’d like to be able to modify my patch and display the content at the same time. But of course if there wasn’t any other option, I could live with that. Although right now I still have a Windows taskbar visible at the bottom, even when I’m in the fullscreen mode - maybe my laptop’s poor graphics card is responsible? All in all, the projected content is distorted.

Does anyone have an advice how should I set it up?

Mayast

Now I opened my patch on another computer, with Windows 7 and nVidia GeForce GTX 690 graphics card. In the screen resolution settings I don’t have the option to duplicate the displays, which is odd. Anyway, setting the renderer to display on the fullscreen still leaves the taskbar and the titlebar visible.

… no text …

Hello Mayast,

This certainly not direct x any limitation as suggested, we all run renderer fullscreen on extended display without any trouble. It happens 1/100 when renderer goes black on fullscreen but even that will work fine on restarting the patch with fullscreen pin set to 1. However, your computer fault i guess(being able to see taskbar on fullscreen is strange), it should be like a cake to move the renderer window to the extended screen and fire up fullscreen. Best is to try the same patch on another computer if possible

Edit: can u post the patch?

I dont understand duplicating your display, are u talking about win+p and choosing how you want to set your display or something within vvvv?

Yes, that’s exactly what I’m talking about: when I use the shortcut Win+P, I see that option, but when I click on it, nothing happens.
When I right click on the desktop and go to screen resolution settings, I only have three options there: extending the display, showing desktop only on screen 1, or only on screen 2. On my laptop (also with Windows 7) I have option no. 4: duplicating (cloning) the display.

Right now I have the projector set as the main screen and the content of the renderer is visible. When it wasn’t the main screen, the renderer window was black or frozen (eg. only one frame of the video was displayed).

I can’t start the patch with fullscreen mode on, because my program works like this:

  1. Placing AR markers on three sides of a box,
  2. Detecting them through camera,
  3. Turning off the ARTK+ tracking node and taking the markers off,
  4. Displaying some textures on the sides of the box (here’s when I need the fullscreen mode).

Ok, I set the fullscreen pin to 1 and it worked (with the projector set as main screen). Earlier I was just clicking twice on the titlebar of the window.

But I’d still like to know why the renderer isn’t working properly when it’s on the second screen (not the main one).

Win+p > set extended > open your patch > keep the patch in your main window and only move your renderer to your extended projector display > make sure you see content on your renderer dragged to extended display > all above is checked then select renderere and hit alt+enter or turn on fullscreen pin to 1 from your patch > do you see the content now on fullscreen?

some times moving the renderer to the extended desktop breaks the patch some how.

when that happens, then save the patch with the renderer on the extended desktop in windowed mode and then close the patch. opening the patch again will most times make the patch run fine again on the second desktop.

Are you using any DShow Nodes for example Video In, Filestream, etc…? They can make some trouble with extended Screens.

Hi, thank you all for your replies.
For now I do everything as Urbankind wrote, with one exception: I keep my patch on the computer display, which is not the main display - the projector is set as the main one, as I mentioned earlier. Anyway, it kinda works. (Only when I want to change the “fullscreen” pin in the renderer back to 0, I get some problems, so I have to close the patch and open it again.)

Alt-Enter on render window.
Or maximize the render and ctrl-8 remove borders